2015 pro-s800 will not rev past 6900rpm & low on power - HCS Snowmobile Forums

Rush/Switchback (AXYS Platform) This is a brand-specific forumand a 100% NO BASH Zone. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree2Likes
  • 1 Post By northstarrick
  • 1 Post By trottlejo
Reply
 
LinkBack Thread Tools
Old 03-09-2020, 08:10 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2020
Posts: 3
Default 2015 pro-s800 will not rev past 6900rpm & low on power

Sled seems slightly under powered, won’t rev past 6900rpm, and tops out at 85mph.Any help on what to check next would be greatly appreciated. Here is a list of things I have done and verified good.
-power valves cleaned, cable is not broken, electric motor does sweep/ move when sled is first started.
- reeds look good
-125psi compression on both cylinders
-both coils produce strong spark
- check engine light is not on
- on Non-ethanol mode & running good fuel
Thanks in advance.
Pray4snow714 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2020, 08:39 PM   #2 (permalink)
Super Advanced Member
 
sleepybrew's Avatar
 
Join Date: Feb 2006
Posts: 3,717
Location: hudson valley ny
Favorite Riding Area: salisbury, speculator, cny
Default

primary spring?
sleepybrew is offline   Reply With Quote
Old 03-09-2020, 08:43 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2020
Posts: 3
Default

The spring is in tact clutch does bang pretty hard when engaging but it has done that for a long time before this
Pray4snow714 is offline   Reply With Quote
 
Old 03-09-2020, 09:29 PM   #4 (permalink)
Super Advanced Member
 
Jesusfreak's Avatar
 
Join Date: Nov 2011
Posts: 814
Current Sled(s): 18' Rush 800 16' Rush 800 Pros 09' 600IQ
Previous Sled(s): 15' 800 Rush Pros,10' Dragon 800 04' 600 Classic, 2002 XC800
Location: Maine
Favorite Riding Area: Western & northern Maine
19-20 Mileage:
18-19 Mileage: 2400
Age: 48
Riding Since: 2005
Default

Belt deflection and how many miles on it? Primary clutch clean, track tension set?
Jesusfreak is offline   Reply With Quote
Old 03-10-2020, 09:29 AM   #5 (permalink)
HCS Advertiser
 
northstarrick's Avatar
 
Join Date: Mar 2011
Posts: 9,995
Default

Quote:
Originally Posted by Pray4snow714 View Post
Sled seems slightly under powered, wonít rev past 6900rpm, and tops out at 85mph.Any help on what to check next would be greatly appreciated. Here is a list of things I have done and verified good.
-power valves cleaned, cable is not broken, electric motor does sweep/ move when sled is first started.
- reeds look good
-125psi compression on both cylinders
-both coils produce strong spark
- check engine light is not on
- on Non-ethanol mode & running good fuel
Thanks in advance.
replace the relays. 2 on the cross tube over the wye pipe. 1 in the bag in front of the oil tank.
xrocket21 likes this.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Northstar Performance Products
Stage 1,2,3 clutch kits
Oil tank vent kits
Doo T-Stat bypass kits
Rush/Axys A-Arm bushing kits
550 fan upgrade kit

Our products have been race tested and proven all across North America!

Authorized dealer for
SLP
RK-Tek
WPS
US Chrome
Thunder Products
Automatic Distributors
Venom/Team Ind.
Redline Oil
Klotz Racing Synthetics
K100
northstarrick is offline   Reply With Quote
Old 03-10-2020, 08:29 PM   #6 (permalink)
Newbie
 
Join Date: Mar 2020
Posts: 3
Default

I did replace the relays. Very rare for a sealed relay to fail typically it’s corrosion on the legs or the connector itself
Pray4snow714 is offline   Reply With Quote
Old 03-10-2020, 11:22 PM   #7 (permalink)
Newbie
 
Join Date: Jan 2015
Posts: 3
Location: Nova Scotia
Default

Check the lines coming off the exhaust valves aren’t plugged off and also check and test the exhaust valve solenoid. Had that problem with my last 2014 800 assault. It would put it in limp mode and come up on the dash “ Detonation “ After changing lines out and cleaning solenoid problem never came back.
Timetogo is offline   Reply With Quote
Old 03-11-2020, 01:29 AM   #8 (permalink)
Super Advanced Member
 
Join Date: Oct 2016
Posts: 3,841
Current Sled(s): 2019 xc indy 840
Previous Sled(s): 2015 prox 17 prox 17 xcr 10 xp 09 nytro 06 apex 05 f7 03 f7
Location: Upstate ny
Favorite Riding Area: Tug hill- old forge
Default

Different valve system
Lid2 is offline   Reply With Quote
Old 03-11-2020, 06:56 AM   #9 (permalink)
Super Advanced Member
 
Join Date: Jan 2009
Posts: 1,107
Current Sled(s): 17 rush prox
Previous Sled(s): xlt ultra xcr 800 04prox
Location: new york
Age: 48
Riding Since: ween
Default

unhook cable from motor and pull to make sure its not broke or hanging up
northstarrick likes this.
trottlejo is offline   Reply With Quote
Old 03-11-2020, 07:04 AM   #10 (permalink)
HCS Advertiser
 
northstarrick's Avatar
 
Join Date: Mar 2011
Posts: 9,995
Default

Quote:
Originally Posted by Pray4snow714 View Post
I did replace the relays. Very rare for a sealed relay to fail typically itís corrosion on the legs or the connector itself
Panasonic or Chinese Polaris o.e.m.? the .50 cent Chinese relays were junk the minute they were put on the boat. the points burn internally on these. electrical parts. going to go a long way to beat japan.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Northstar Performance Products
Stage 1,2,3 clutch kits
Oil tank vent kits
Doo T-Stat bypass kits
Rush/Axys A-Arm bushing kits
550 fan upgrade kit

Our products have been race tested and proven all across North America!

Authorized dealer for
SLP
RK-Tek
WPS
US Chrome
Thunder Products
Automatic Distributors
Venom/Team Ind.
Redline Oil
Klotz Racing Synthetics
K100
northstarrick is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:13 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.