Stock deck to exhaust port measurement - HCS Snowmobile Forums

Rush/Switchback (AXYS Platform) This is a brand-specific forumand a 100% NO BASH Zone. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree1Likes
Reply
 
LinkBack Thread Tools
Old 05-11-2019, 10:37 PM   #1 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default Stock deck to exhaust port measurement

As post says, Does anyone know what the stock measurement might be on an 2018 xcr 800?
booboo is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-12-2019, 05:33 PM   #2 (permalink)
Super Advanced Member
 
Meat Head's Avatar
 
Join Date: Sep 2004
Posts: 3,557
Current Sled(s): 800 Etec
Previous Sled(s): Pile of shit D8
Location: MI
Default

Local speed shop ported this sled, trying to verify it actually was done. Appears to not have been done. Still has a sand cast look.
This sled carries a back story worth telling, however the owner should post that once we determine what's been done.
I will say this the fix kit doesn't fix anything on the ho engine...
Meat Head is offline   Reply With Quote
Old 05-15-2019, 08:26 PM   #3 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default

No need for measurements.. there was no porting done.. Good thing I payed priceless performance to port it... $3200 for junk
Attached Thumbnails
Click image for larger version

Name:	89.jpeg
Views:	59
Size:	151.2 KB
ID:	2053826  
booboo is online now   Reply With Quote
 
Old 05-15-2019, 08:29 PM   #4 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default

Second time it locked up.. got bout 400miles out of it both times and before it went down..
booboo is online now   Reply With Quote
Old 05-15-2019, 08:32 PM   #5 (permalink)
Super Advanced Member
 
Fun11cat's Avatar
 
Join Date: Apr 2009
Posts: 2,543
Current Sled(s): 2020 ZR 8000 LTD IACT - 14 XF7000 Ltd Org/Blk
Previous Sled(s): 10 F8 SP,05 F6,02 ZL 600SS, 99 ZL 600, 96 Pantera
Location: Little Falls, MN
Favorite Riding Area: Central MN
19-20 Mileage: 125
18-19 Mileage: 1170
17-18 Mileage: 1260
16-17 Mileage: 960
Age: 59
Riding Since: 1972
Default

OUCH

Price per mile and down time is not your friend on this motor.

Will they back there work and redo the motor for you.
Fun11cat is online now   Reply With Quote
Old 05-15-2019, 08:34 PM   #6 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default

Pretty pissed about Priceless screwing me.. long story short i called him about a bb kit.. instead he talk me into this kit that was supposed to be similar power and more reliable... well 800 miles and now 2 motors and he no longer reply back to me.. what's really sad is it wasnt any faster then stock.. payed him $3200 for nothing.. I think I put more miles on my boots walking g this passed winter then I did riding..

Last edited by booboo; 05-15-2019 at 08:40 PM.
booboo is online now   Reply With Quote
Old 05-15-2019, 08:36 PM   #7 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default

Nope sent him that pics and he wont answer me back
booboo is online now   Reply With Quote
Old 05-15-2019, 08:48 PM   #8 (permalink)
Super Advanced Member
 
Meat Head's Avatar
 
Join Date: Sep 2004
Posts: 3,557
Current Sled(s): 800 Etec
Previous Sled(s): Pile of shit D8
Location: MI
Default

True story, no bs either. I pulled that pile of priceless junk out of the woods both times.

Unfortunately the story is worse than this. Slow turn around time to what might have been the all time slowest and poorly executed clutch set up I have ever seen. Really and nerd could have picked a better set up..
So stay away boys, I have held my tongue on this one long enough, he's had his chance to be a man and man up.
Meat Head is offline   Reply With Quote
Old 05-15-2019, 09:00 PM   #9 (permalink)
Super Advanced Member
 
booboo's Avatar
 
Join Date: Nov 2007
Posts: 1,918
Current Sled(s): 18 XCR 800
Previous Sled(s): Cat, Poo, Cat, Yamie
Location: Northern MI
Favorite Riding Area: ON TOP OF THE WIFE
19-20 Mileage:
18-19 Mileage: Not bad
17-18 Mileage: All U.P. miles
16-17 Mileage: Not enough
Age: 43
Riding Since: 99
Default

Promised me dyno time to tune this setup.. but that never happened.. wasnt faster then stock.. the stock Doo 850 would smoke me.. I payed priceless to pipe, port, head kit, and different piston to make my sled run.. he did all the work and it wasn't any faster then stock.. only thing fast about was how fast it went down

Last edited by booboo; 05-15-2019 at 09:02 PM.
booboo is online now   Reply With Quote
Old 05-16-2019, 03:24 PM   #10 (permalink)
Super Advanced Member
 
Join Date: Jan 2007
Posts: 600
Current Sled(s): 15 Pro s 800
Previous Sled(s): 03 f7,00 xcr 800,00 xc600sp,96 ultra,89 650,v-max 540, SS440
Location: northern il
Favorite Riding Area: Up
Age: 40
Riding Since: 4
Default

I had the same issue with another well known shops porting. mine ran great for the first 50-100 miles then would start falling off 400-500 miles max. Pistons look identical to yours. I was told it was from lack of lubrication even though I had extra oil in the gas along with the controller adding extra oil also.
jfaub63 is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Max tune on stock exhaust Webby 1100 Turbo 4 Stroke 14 01-31-2019 09:24 PM
Stock Exhaust Tune Crushed It Turbo 4 Stroke 10 10-25-2018 04:55 PM
RMSHA results Bigfuse General Discussion Forum 172 05-12-2016 01:48 PM
Schuss Mountain Hill Climb April 8th & 9th 2016 yzrp.com Michigan 62 04-14-2016 10:01 AM
Schuss Mountain Class (UPDATE) yzrp.com Michigan 0 03-28-2016 01:25 PM


All times are GMT -4. The time now is 11:19 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.