2012 F800 Sno Pro leaking oil - HCS Snowmobile Forums

ProCross (2012 - ) F+ XF 800/1100/ This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree1Likes
  • 1 Post By bowanna03
Reply
 
LinkBack Thread Tools
Old 09-05-2019, 11:31 AM   #1 (permalink)
Member
 
Join Date: Mar 2018
Posts: 12
Location: Cuse
Default 2012 F800 Sno Pro leaking oil

Please see the attached pictures. I purchased this sled and haven't even used it yet and noticed the other day that it is leaking oil from the bottom of the sled and it looks like a decent amount and consistent. I am going to purchase a service manual but was wondering if anyone has had the same issue and if they know what could be causing it or needs to be repaired
Attached Thumbnails
Click image for larger version

Name:	IMG_20190831_163240547.jpg
Views:	48
Size:	197.9 KB
ID:	2056842   Click image for larger version

Name:	IMG_20190831_163245704_HDR.jpg
Views:	45
Size:	276.2 KB
ID:	2056844  
bowanna03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-05-2019, 12:33 PM   #2 (permalink)
Super Advanced Member
 
Procross225's Avatar
 
Join Date: Sep 2008
Posts: 1,308
Previous Sled(s): Lots of Cats
Location: Minnesota
Favorite Riding Area: Northern Minnesota
19-20 Mileage:
18-19 Mileage: 550
17-18 Mileage: 715
16-17 Mileage: 500
Age: 31
Riding Since: 1993
Default

Looks like your airbox is filling with oil from the reed lines. Odd the oil is red. If it was coming from chaincase area id expect it to be wet in that area but its not.

Try cleaning up a good portion, loosen oil cap and see if it stops. Your cap may not be venting and its forcing built up pressure through the pump to the reed housings and filling up your air box
Procross225 is online now   Reply With Quote
Old 09-05-2019, 02:15 PM   #3 (permalink)
Member
 
Join Date: Mar 2018
Posts: 12
Location: Cuse
Default

Thank you!!!
bowanna03 is offline   Reply With Quote
Old 09-06-2019, 12:30 AM   #4 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,408
Current Sled(s): "Agri-vator"
Default

What he said. Pretty common, and not an issue. (As long as your cap is venting. If it doesn't rattle when you rattle it, replace it). Looks like your hood was On in those pics. Remove it and look in the air box, you'll likely see a red puddle. We have learned not to store the sled's with the oil tanks very full, as that adds to expansion and pressure that pushes on the checkvvalves
stronger800 is offline   Reply With Quote
Old 09-06-2019, 08:20 AM   #5 (permalink)
Member
 
Join Date: Mar 2018
Posts: 12
Location: Cuse
Default

Thank you for your help with this! Much appreciated
bowanna03 is offline   Reply With Quote
Old 09-06-2019, 12:00 PM   #6 (permalink)
Super Advanced Member
 
SShooterZ's Avatar
 
Join Date: Mar 2008
Posts: 517
Current Sled(s): 2017 ZR8000 SP
Previous Sled(s): 2003 Z440 SP | 2002 ZR600 | 2000 ZR600 | 1996 580EXT EFI
Location: McHenry, IL
Default

Quote:
Originally Posted by Procross225 View Post
Odd the oil is red.
Could be Ski Doo XPS. It looks a lot like it.
SShooterZ is offline   Reply With Quote
Old 09-06-2019, 12:17 PM   #7 (permalink)
The Meat Man
 
Badger's Avatar
 
Join Date: Apr 2009
Posts: 14,540
Current Sled(s): MY19 850 Doo mXz TnT
Previous Sled(s): Black MY15 ProS 800 SB ANV
Location: In a van down by the river.
Favorite Riding Area: Summit Lake WI
Riding Since: 1776
Default

Check you oil cap I had a bad one and in the summer the sled would leak oil all over the place. it's a long shot but it happen on my 2003.
__________________
"The Meat Man"

Sent from my HP Media Center Via RoadRunner...so bite me.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Badger is offline   Reply With Quote
Old 09-06-2019, 02:46 PM   #8 (permalink)
Member
 
Join Date: Mar 2018
Posts: 12
Location: Cuse
Default

I took the oil cap off and shook it and I could hear a rattle. I loosened it and put it back on. I also cleaned the bottom off and after two days there is nothing showing leaking yet
SShooterZ likes this.
bowanna03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:07 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.