AC/DC converter "update" - Page 2 - HCS Snowmobile Forums

Fusion This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree2Likes
Reply
 
LinkBack Thread Tools
Old 01-14-2018, 03:33 PM   #11 (permalink)
Administrator
 
sayatodaU.P.eh?'s Avatar
 
Join Date: Nov 2003
Posts: 24,009
Current Sled(s): 2015 RMK 800
Previous Sled(s): 600 H.O. Fusion
Location: Michigan
Default AC/DC converter "update"

Ah! I thought they were crimp and seals.

Just looked them up. $19 for 50 on EBay or $22 for 100 from Amazon. Gonna get the 100 from Amazon and give them a shot. I usually solder and shrink tube all my wiring connections but solder and seal shrink connectors are pretty handy in place of actual solder/shrink tube.
sayatodaU.P.eh? is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-16-2018, 12:52 AM   #12 (permalink)
cfm
Super Advanced Member
 
Join Date: Nov 2005
Posts: 5,664
Current Sled(s): 900 Fuse-10,800miles and going / 06 600HO M10
Location: Dirt Floor in NH
Riding Since: 3 BC
Default

Quote:
Originally Posted by sledge8 View Post
part # 4011829 crosses to 08 RMK 600 shift.
If you can make your own harness or mount it down by the old one you could save some $$$. The new one is taller and mounts different so I don't think it would fit under the oil bottle / jack shaft like the original one.
Well, that sucks.

#4011829 is discontinued and they don't show a supercede #. I've looked several places.

https://www.babbittsonline.com/oempa...cal-components
__________________
PPP Charter Member #2

-"Your motor will tell you what it wants. Are you listening ?" - Darin Morgan
- "Look at the way they flew in the slew. Hats off to you. Woopy Doo!" - ICEMANJOE
cfm is offline   Reply With Quote
Old 01-16-2018, 09:47 AM   #13 (permalink)
Super Advanced Member
 
drewma's Avatar
 
Join Date: Oct 2007
Posts: 1,718
Current Sled(s): Polaris 2006 600 Fusion Dragon
Previous Sled(s): 74 and counting
Location: NW suburb of water crisis USA...cottage in Boyne City
Favorite Riding Area: Elmira, Michigan
19-20 Mileage: 1
18-19 Mileage: 900
17-18 Mileage: 404
16-17 Mileage: 900
Age: 53
Riding Since: 1970
Default

Quote:
Originally Posted by cfm View Post
Well, that sucks.

#4011829 is discontinued and they don't show a supercede #. I've looked several places.

https://www.babbittsonline.com/oempa...cal-components
Wonder if kit #2203794 is still available?
drewma is offline   Reply With Quote
 
Old 02-18-2018, 10:02 AM   #14 (permalink)
Member
 
Join Date: Feb 2018
Posts: 16
Current Sled(s): Polaris 800 Switchback Pro-X -15
Previous Sled(s): Polaris IQ 600 HO -07, Yamaha V-max 500 -98
Location: Sweden
Age: 35
Riding Since: 2003
Default

Quote:
Originally Posted by drewma View Post
Wonder if kit #2203794 is still available?
yup here at least www . polarispartshouse . com
malbeat is offline   Reply With Quote
Old 02-18-2018, 07:21 PM   #15 (permalink)
Super Advanced Member
 
fastmod62's Avatar
 
Join Date: Nov 2006
Posts: 286
Current Sled(s): 2019 800 SB Pro S , 2017 600 Rush Pro S
Previous Sled(s): 15 800 SB Pro S, 1980 Liquifire
Location: Illinois
Favorite Riding Area: Northwoods, WI and the Yooper
19-20 Mileage:
18-19 Mileage: 1000
17-18 Mileage: 800
16-17 Mileage: 800
Age: 52
Riding Since: 1978
Default

Quote:
Originally Posted by malbeat View Post
yup here at least www . polarispartshouse . com
Available at www. partspitstop also
$200.90
fastmod62 is offline   Reply With Quote
Old 03-18-2018, 07:04 AM   #16 (permalink)
Member
 
Join Date: Feb 2018
Posts: 16
Current Sled(s): Polaris 800 Switchback Pro-X -15
Previous Sled(s): Polaris IQ 600 HO -07, Yamaha V-max 500 -98
Location: Sweden
Age: 35
Riding Since: 2003
Default

Edit: Solved it, see the tread/link below

I ordered and installed the kit.. the display is now dead as a stone. More info here: https://www.hardcoresledder.com/foru...l#post19705289

Edit: Wrong, nothing wrong with the display/MFD but something is wrong. Either i got a lemon VR or i have some short screwing with me.
I get 0.6v DC+/DC GND but around 14V DC+/AC GND. The MFD works when grounded to AC GND so my conclusion is DC GND is screwed up somehow.

Last edited by malbeat; 03-21-2019 at 05:32 AM.
malbeat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:44 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.