2011 Skidoo Renegade 1200 4tec blown engine - Page 3 - HCS Snowmobile Forums

4-TEC / Ace 4 Strokes This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 03-29-2016, 11:41 AM   #21 (permalink)
Super Advanced Member
 
skidont's Avatar
 
Join Date: Dec 2003
Posts: 2,486
Current Sled(s): 2015 1200 renegade
Previous Sled(s): ALOT !!
Location: North Branch , Mn
Favorite Riding Area: northern wis - northern Mn
19-20 Mileage:
18-19 Mileage: 3117
17-18 Mileage: 2066
16-17 Mileage: 1936
Age: 54
Riding Since: 1968
Default

Quote:
Originally Posted by tic View Post
Funny another guy just posted in the 1200 forum on dootalk saying he lost the motor on his sled, no other details... I hope he finds it
LOL
skidont is offline   Reply With Quote
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:02 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.