2012 gsx se 800 air shock issue - HCS Snowmobile Forums

XP/XR/XS New Style MXZ This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 01-02-2020, 02:28 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2020
Posts: 1
Default 2012 gsx se 800 air shock issue

Hi all. I'm very new here and first post. I've recently purchased this sled with not very much research. Air ride, heated seats woohoo that's about the research I did. As of now the sled works as it should. I think?????? As of now the shock is flat, so I start the sled the suspension pumps up I can adjust the different settings up to 5. If I go down to say 3 I hear a pffffft air release that's good I think. And repeat. Up to 5 down to 3. All works. The question is, is it supposed to drop flat when it is off? Or hold the current air pressure? Do I have a leak? I've seen multiple multiple forums of this crappy air system but have not been able to find anything about my question. Any information please. The machine has hi mileage 16000k bought out of Quebec, I don't have many details as the owner only had it for two years. And says he did a track and drive /chaincase seals and bearings. The dealer is pulling up one warranty repair on the computer but no details to what was done. I was told not to worry that much about the high mileage as it was out of Quebec and that their trails are beautiful, and comparing to selling a car is like the seller saying "it's all highway miles". Here in Ontario we still have no snow and hopefully In the next few weeks. So I have a couple weeks to get this fixed. I've also read forums of changing the shock to a standard XP shock. Any information on that too would be appreciated.

Thx keith
Keith1000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2020, 11:26 PM   #2 (permalink)
Super Advanced Member
 
ddhanna's Avatar
 
Join Date: Jan 2006
Posts: 406
Current Sled(s): '18 Doo Renegade Enduro 900
Previous Sled(s): Rupp, POOs
Location: Three Lakes, WI
Favorite Riding Area: Northern WI
Age: 62
Riding Since: 1972
Default

Quote:
Originally Posted by Keith1000 View Post
Hi all. I'm very new here and first post. I've recently purchased this sled with not very much research. Air ride, heated seats woohoo that's about the research I did. As of now the sled works as it should. I think?????? As of now the shock is flat, so I start the sled the suspension pumps up I can adjust the different settings up to 5. If I go down to say 3 I hear a pffffft air release that's good I think. And repeat. Up to 5 down to 3. All works. The question is, is it supposed to drop flat when it is off? Or hold the current air pressure? Do I have a leak? I've seen multiple multiple forums of this crappy air system but have not been able to find anything about my question. Any information please. The machine has hi mileage 16000k bought out of Quebec, I don't have many details as the owner only had it for two years. And says he did a track and drive /chaincase seals and bearings. The dealer is pulling up one warranty repair on the computer but no details to what was done. I was told not to worry that much about the high mileage as it was out of Quebec and that their trails are beautiful, and comparing to selling a car is like the seller saying "it's all highway miles". Here in Ontario we still have no snow and hopefully In the next few weeks. So I have a couple weeks to get this fixed. I've also read forums of changing the shock to a standard XP shock. Any information on that too would be appreciated.

Thx keith
I have the same sled in a 600. It should hold air pressure.
ddhanna is offline   Reply With Quote
Old 01-02-2020, 11:39 PM   #3 (permalink)
Super Advanced Member
 
Drift19's Avatar
 
Join Date: Jan 2019
Posts: 437
Current Sled(s): 2014 Ski Doo GSX SE 600 etec
Previous Sled(s): Cats, Polaris, and Ski Doo
Location: North of Minneapolis
Favorite Riding Area: Hayward WI area, Up North
Riding Since: 16
Default

Quote:
Originally Posted by ddhanna View Post
I have the same sled in a 600. It should hold air pressure.
X2 I have a 2014 GSX SE 600 and the shock should hold air and stays at the last setting.
Drift19 is offline   Reply With Quote
 
Old 01-02-2020, 11:43 PM   #4 (permalink)
Super Advanced Member
 
Drift19's Avatar
 
Join Date: Jan 2019
Posts: 437
Current Sled(s): 2014 Ski Doo GSX SE 600 etec
Previous Sled(s): Cats, Polaris, and Ski Doo
Location: North of Minneapolis
Favorite Riding Area: Hayward WI area, Up North
Riding Since: 16
Default

Quote:
Originally Posted by Keith1000 View Post
Hi all. I'm very new here and first post. I've recently purchased this sled with not very much research. Air ride, heated seats woohoo that's about the research I did. As of now the sled works as it should. I think?????? As of now the shock is flat, so I start the sled the suspension pumps up I can adjust the different settings up to 5. If I go down to say 3 I hear a pffffft air release that's good I think. And repeat. Up to 5 down to 3. All works. The question is, is it supposed to drop flat when it is off? Or hold the current air pressure? Do I have a leak? I've seen multiple multiple forums of this crappy air system but have not been able to find anything about my question. Any information please. The machine has hi mileage 16000k bought out of Quebec, I don't have many details as the owner only had it for two years. And says he did a track and drive /chaincase seals and bearings. The dealer is pulling up one warranty repair on the computer but no details to what was done. I was told not to worry that much about the high mileage as it was out of Quebec and that their trails are beautiful, and comparing to selling a car is like the seller saying "it's all highway miles". Here in Ontario we still have no snow and hopefully In the next few weeks. So I have a couple weeks to get this fixed. I've also read forums of changing the shock to a standard XP shock. Any information on that too would be appreciated.

Thx keith

You should be able to get the shock fixed. Probably just a bad seal. The air ride is nice. On the fly adjust to different trail conditions.
Drift19 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:35 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.