Dead as a rock... - Page 3 - HCS Snowmobile Forums

FST/4 stroke This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree3Likes
Reply
 
LinkBack Thread Tools
Old 08-27-2019, 10:31 PM   #21 (permalink)
Super Advanced Member
 
patrioticinnovations's Avatar
 
Join Date: Sep 2005
Posts: 15,019
Current Sled(s): 2015 AXYS Pr-S SB Ann 800, 2019 Indy 850.
Previous Sled(s): 2003 XCR 1100, 2000 XCR 800 turbo, 2005 Redline Revolt 800.
Location: SE Lower Michigan
Favorite Riding Area: Cadillac, Gaylord
19-20 Mileage: 715 so far
18-19 Mileage: 849
17-18 Mileage: 1280
16-17 Mileage: 1115
Riding Since: 1982
Default

Quote:
Originally Posted by IH8Summer View Post
So iíve tested all the relays. All click with power supplied and show 0 ohm resistance. Replacing them anyways when they come in the mail.

I crossed the solenoid posts and it turns over fine. Still zero life to gauges, efi, etc.

Im thinking kill switch is bad or grounding out somewhere, but i have a question. When the key is turned, how many prongs on the key switch should be sending current? So far as I can tell, only one is on mine.
Probably only one if just powering the display. Two if cranking. EFI likely doesn't run off the battery.
patrioticinnovations is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-04-2019, 02:35 PM   #22 (permalink)
Super Advanced Member
 
Join Date: Aug 2014
Posts: 250
Current Sled(s): 2015 Ski-Doo Renegade X 800 ETEC
Previous Sled(s): 2000 Polaris 700 SKS, 2010 Polaris IQ Turbo Dragon
Location: Wisconsin
Favorite Riding Area: Turtle Flambeau Flowage
19-20 Mileage:
18-19 Mileage: 2143
17-18 Mileage: 1565
16-17 Mileage: 1980
Age: 21
Riding Since: 2007
Default

Well my key is sending power from one of the terminals but nothing happens. That probably means it's grounding out somewhere then.
__________________
2015 Ski-Doo Renegade X 800R ETEC
IH8Summer is offline   Reply With Quote
Old 10-03-2019, 06:16 PM   #23 (permalink)
Super Advanced Member
 
Join Date: Aug 2014
Posts: 250
Current Sled(s): 2015 Ski-Doo Renegade X 800 ETEC
Previous Sled(s): 2000 Polaris 700 SKS, 2010 Polaris IQ Turbo Dragon
Location: Wisconsin
Favorite Riding Area: Turtle Flambeau Flowage
19-20 Mileage:
18-19 Mileage: 2143
17-18 Mileage: 1565
16-17 Mileage: 1980
Age: 21
Riding Since: 2007
Default

Another question: are the relays for the FST's open until closed or closed until open? I got some advice from someone the other day I've been mulling over but I'm not sure it's accurate.

I was debating disconnecting the key, as the key (theoretically) is what closes the circuit if they are open until closed. At that point if I jumped the solenoid posts the relays would all open and therefore, assuming no other unknown problems, start the sled. Does this add up?
__________________
2015 Ski-Doo Renegade X 800R ETEC
IH8Summer is offline   Reply With Quote
 
Old 10-23-2019, 05:50 PM   #24 (permalink)
Super Advanced Member
 
Join Date: Sep 2005
Posts: 149
Current Sled(s): 2013 Ski Doo 1200 & 2006 FST Classic
Previous Sled(s): 2003 Polaris 700 Classic
Favorite Riding Area: WI Northwoods
19-20 Mileage:
18-19 Mileage: 3500
16-17 Mileage: 2500
Age: 66
Riding Since: 1978
Default

Did you ever replace the relays or switch out the EFI relay with the chassis relay? Have you ever unplugged the ignition switch? If so you can plug the wires back on incorrectly. It's also possible the the ignition switch to be bad.
__________________
2006 FST Classic with 180 degree thermostat, notched drive shaft shield, re-routed/shielded wiring harness, block heater installed on bottom of engine, adjusted gas tank float, oil pressure light, Autometer boost gauge, Camoplast Ice Attack track, Snobeelers shock recalibration, cyclone hose re-routed to exhaust, 24-44 gears, YaYou's Stage 2 re-flash, helix and alternator pulley.
dofo1 is offline   Reply With Quote
Old 11-04-2019, 06:02 PM   #25 (permalink)
Super Advanced Member
 
Join Date: Aug 2014
Posts: 250
Current Sled(s): 2015 Ski-Doo Renegade X 800 ETEC
Previous Sled(s): 2000 Polaris 700 SKS, 2010 Polaris IQ Turbo Dragon
Location: Wisconsin
Favorite Riding Area: Turtle Flambeau Flowage
19-20 Mileage:
18-19 Mileage: 2143
17-18 Mileage: 1565
16-17 Mileage: 1980
Age: 21
Riding Since: 2007
Default

Quote:
Originally Posted by dofo1 View Post
Did you ever replace the relays or switch out the EFI relay with the chassis relay? Have you ever unplugged the ignition switch? If so you can plug the wires back on incorrectly. It's also possible the the ignition switch to be bad.
Yeah i did unplug it. While I was home briefly I unplugged the key switch and crossed the solenoid posts. Nada. Might just take it in as I don't have time to check through every wire on the sled.
__________________
2015 Ski-Doo Renegade X 800R ETEC
IH8Summer is offline   Reply With Quote
Old 12-29-2019, 03:25 PM   #26 (permalink)
Super Advanced Member
 
Join Date: Sep 2005
Posts: 149
Current Sled(s): 2013 Ski Doo 1200 & 2006 FST Classic
Previous Sled(s): 2003 Polaris 700 Classic
Favorite Riding Area: WI Northwoods
19-20 Mileage:
18-19 Mileage: 3500
16-17 Mileage: 2500
Age: 66
Riding Since: 1978
Default

Did you ever get it running?
__________________
2006 FST Classic with 180 degree thermostat, notched drive shaft shield, re-routed/shielded wiring harness, block heater installed on bottom of engine, adjusted gas tank float, oil pressure light, Autometer boost gauge, Camoplast Ice Attack track, Snobeelers shock recalibration, cyclone hose re-routed to exhaust, 24-44 gears, YaYou's Stage 2 re-flash, helix and alternator pulley.
dofo1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hurricane at race on the rock hurricaneperformance Turbo 4 Stroke 3 04-14-2018 11:09 PM
Not starting dead after boosting Bskilliter2017! IQ chassis 0 12-15-2017 10:43 AM
Rock music you just can't gut? dodger General Discussion Forum 53 12-31-2016 11:30 AM
South Bend Service - Don Rock 3illmesmart General Snowmobile Forum 1 08-10-2016 03:28 PM
Rangeley Rock Maple & Pro Vintage Race jonny dw Maine 2 03-15-2016 02:24 PM


All times are GMT -4. The time now is 01:29 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.