Post any problems on the 2008 F-Series here, Post Defects your finding after delivery - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 09-02-2007, 02:42 PM   #1 (permalink)
Doesn't play well with other
 
Flash and Flare's Avatar
 
Join Date: Dec 2002
Posts: 5,437
Current Sled(s): 2013 F800 RR-K
Previous Sled(s): Pantera Deluxe Touring, F120mod, z370, 87 5000 89 6000
Location: Wisconsin
Age: 41
Riding Since: 1981
Default

Please lets post all issues here so topics of interest don't get lost in the shuffle as the season picks up.
Any comments non-related or of bashing nature will be removed.
I pinned this to help everyone, lets keep it on track and save the pissing match comments for the General Forum.

Flash and Flare
__________________
Real sedans don't have spark plugs ! BORA TDI


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


You gotta ask yourself how serious you are about going fast.
1. Cheap
2. Fast
3. Reliable
Pick two cause you can't have all 3 at the same time.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Flash and Flare is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-09-2007, 03:22 PM   #2 (permalink)
Super Advanced Member
 
old cat man's Avatar
 
Join Date: Dec 2002
Posts: 5,552
Current Sled(s): 2014 ZR6000,06 XF 6SP
Previous Sled(s): bunch of cats
Location: Appleton,WI
19-20 Mileage:
18-19 Mileage: 550
Default

Haven't really gotten to deep into mine yet, but first thing I notice much better clutch cover design over my 07! I'll keep you posted as my project continues.
old cat man is offline   Reply With Quote
Old 09-15-2007, 10:23 AM   #3 (permalink)
Super Advanced Member
 
Join Date: Dec 2004
Posts: 315
Current Sled(s): 2010 MXZ 800X
Previous Sled(s): 03 ZR900 Sno Pro
Location: MA
Favorite Riding Area: Burg or Bust
Riding Since: 2000
Default

When running the motor watch out when you have the hood up. It may rub on the nose. I bent the stopper tabs on the hood up a bit to prevent this.
LarryV is offline   Reply With Quote
 
Old 09-18-2007, 04:10 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Dec 2004
Posts: 315
Current Sled(s): 2010 MXZ 800X
Previous Sled(s): 03 ZR900 Sno Pro
Location: MA
Favorite Riding Area: Burg or Bust
Riding Since: 2000
Default

Tracking rubbing on diamond drive bolts just like 07's
LarryV is offline   Reply With Quote
Old 09-19-2007, 12:01 PM   #5 (permalink)
Super Advanced Member
 
zr84evr's Avatar
 
Join Date: Mar 2006
Posts: 1,981
Current Sled(s): 08 F8 Sno Pro
Previous Sled(s): 02 ZR 800 CC
Location: Fenton, MI
Favorite Riding Area: Da U.P.
Default

Quote:
Tracking rubbing on diamond drive bolts just like 07's[/b]

You have got to be kidding me.
Guess I'll be taking a look at that when I pick it up.
__________________
Drive it like you stole it!!!!!!!
zr84evr is offline   Reply With Quote
Old 09-19-2007, 03:37 PM   #6 (permalink)
Super Advanced Member
 
old cat man's Avatar
 
Join Date: Dec 2002
Posts: 5,552
Current Sled(s): 2014 ZR6000,06 XF 6SP
Previous Sled(s): bunch of cats
Location: Appleton,WI
19-20 Mileage:
18-19 Mileage: 550
Default

Quote:
Tracking rubbing on diamond drive bolts just like 07's[/b]

X2 and Cat should have a new part for that by Nov I was told from my dealer. But, that will be a big job for all 08's you have to take out the DD and I think the track will have to be dropped also to replace that part.
old cat man is offline   Reply With Quote
Old 09-24-2007, 12:22 PM   #7 (permalink)
Super Advanced Member
 
fastf7rider's Avatar
 
Join Date: Oct 2006
Posts: 229
Current Sled(s): 20 R-XC, 17 ZR6000 RS, 18 ZR200
Previous Sled(s): 13 F8 SP, 12 F1100 50th, 08 F6SP, 06 F7SP, 03 F7
Location: Victor, NY
Favorite Riding Area: Tug Hill & Old Forge NY
Age: 40
Default

I picked up my sled last week and verified the track is definitely rubbing on the DD bolts.

I spoke to my dealer about this issue and the dealer told me that he spoke to the factory and the factory rep told him that it is normal for the track to shift from side to side. He told me they didnt see any issues with this problem last year and he doesnt expect it to be an issue with my sled either. Does this make sense to you guys?
fastf7rider is offline   Reply With Quote
Old 09-24-2007, 03:43 PM   #8 (permalink)
Super Advanced Member
 
Join Date: Dec 2004
Posts: 315
Current Sled(s): 2010 MXZ 800X
Previous Sled(s): 03 ZR900 Sno Pro
Location: MA
Favorite Riding Area: Burg or Bust
Riding Since: 2000
Default

Quote:
I picked up my sled last week and verified the track is definitely rubbing on the DD bolts.

I spoke to my dealer about this issue and the dealer told me that he spoke to the factory and the factory rep told him that it is normal for the track to shift from side to side. He told me they didnt see any issues with this problem last year and he doesnt expect it to be an issue with my sled either. Does this make sense to you guys?[/b]
Nope that doesn't make sense, because it is not from shifting side to side. Mine is aligned AWAY from the DD and is still rubbing. My dealer called Cat tech and they said they have heard this from another dealer as well. It's a problem and is not normal. The factory rep is FULL OF SH_T!!!!!! My track is already showing the cord on the DD side and it has .1 miles on it. Yes 0.1 miles not 1. You can see on mine where it hits the DD bolt and starts to buckle in. Definite design flaw. Let's hope the other guy's info on a fix in November is correct. No fix = Cat getting their sled back.
LarryV is offline   Reply With Quote
Old 09-24-2007, 11:03 PM   #9 (permalink)
Super Advanced Member
 
fastf7rider's Avatar
 
Join Date: Oct 2006
Posts: 229
Current Sled(s): 20 R-XC, 17 ZR6000 RS, 18 ZR200
Previous Sled(s): 13 F8 SP, 12 F1100 50th, 08 F6SP, 06 F7SP, 03 F7
Location: Victor, NY
Favorite Riding Area: Tug Hill & Old Forge NY
Age: 40
Default

Quote:
Nope that doesn't make sense, because it is not from shifting side to side. Mine is aligned AWAY from the DD and is still rubbing. My dealer called Cat tech and they said they have heard this from another dealer as well. It's a problem and is not normal. The factory rep is FULL OF SH_T!!!!!! My track is already showing the cord on the DD side and it has .1 miles on it. Yes 0.1 miles not 1. You can see on mine where it hits the DD bolt and starts to buckle in. Definite design flaw. Let's hope the other guy's info on a fix in November is correct. No fix = Cat getting their sled back.[/b]

How are you going to get them to give you your money back? I paid cash for mine. Are you going to sue them or what??? This sled is my first experience with this particular dealer. I had great service on my last 3 sleds from my previous dealer, but he wouldnt budge on price for the 08 and I saved almost $1500 by driving 40 miles. I hope I dont regret it.
fastf7rider is offline   Reply With Quote
Old 09-25-2007, 09:58 AM   #10 (permalink)
Super Advanced Member
 
Join Date: Dec 2004
Posts: 315
Current Sled(s): 2010 MXZ 800X
Previous Sled(s): 03 ZR900 Sno Pro
Location: MA
Favorite Riding Area: Burg or Bust
Riding Since: 2000
Default

Quote:
How are you going to get them to give you your money back? I paid cash for mine. Are you going to sue them or what??? This sled is my first experience with this particular dealer. I had great service on my last 3 sleds from my previous dealer, but he wouldnt budge on price for the 08 and I saved almost $1500 by driving 40 miles. I hope I dont regret it.[/b]
Nope, I know the GM of the dealer I bought it from and already spoke to him about taking it back. He knows I will be more than happy to spend my money with him. I'll get an Apex RTX instead. I would prefer Cat to just come up with a legitimate fix as I want the F1000, and I already put $1000 in accessories on it. We will see what happens.
LarryV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:19 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.