F1000 rod bearing failure - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-28-2020, 11:12 AM   #1 (permalink)
Super Advanced Member
 
Cap'n Pete's Avatar
 
Join Date: Feb 2007
Posts: 1,508
Current Sled(s): '08 F1000 Nightfire
Previous Sled(s): F7, T-Cat, ZR700, Sno-Scoot
Location: Oshawa, Ont.
Favorite Riding Area: Paudash/Bancroft
Riding Since: 1990
Default F1000 rod bearing failure

Well, it had a good ~6500 mile run. Motor went down a week ago while doing the RAP tour, just outside of Pembroke. Finally got 'er opened up yesterday to see what happened. Clutch side rod bearing gonzo. I can't even see any needle bearings in there ... just shiny smooth metal!?!

Aside from the obvious damage, looks like the cylinder may be ok, minus a very small nick near the top edge.

Of course this had to happen during the peak of our winter season!

Hopefully all parts arrive and I can have it back up and running in a few days.
Attached Thumbnails
Click image for larger version

Name:	F1000 engine (1).jpg
Views:	13
Size:	269.6 KB
ID:	2076848   Click image for larger version

Name:	F1000 engine (3).jpg
Views:	10
Size:	276.1 KB
ID:	2076850   Click image for larger version

Name:	F1000 engine (6).jpg
Views:	10
Size:	157.4 KB
ID:	2076852  
Cap'n Pete is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2020, 05:39 PM   #2 (permalink)
Super Advanced Member
 
thundercat900's Avatar
 
Join Date: Jan 2005
Posts: 826
Current Sled(s): 07 F1000
Previous Sled(s): 93 Thundercat
Location: Guelph, Ontario
Favorite Riding Area: Anywhere there is snow.
Riding Since: 1988
Default

Shit that sucks. I've got 15.5k on mine and the last few years been going to rebuild but haven't had the time. Running 50-55 to 1 amsoil interceptor. Thing is it runs so dam good. Guess this summer I will have to do it ��
__________________
2011 Z1 Turbo EXT- TD stage 2, mod turbo, bikeman outlet, K&N intake
2007 F1000- D&D y-pipe, Boondocker, STM Valves, BMP stage 2 clutching, Rox Bar Risers, Plowman Mount, Shocks Re-Valved by Peak Velocity
thundercat900 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:48 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.