2007 F5 LXR new to me - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 04-12-2019, 10:35 AM   #1 (permalink)
Member
 
Join Date: Mar 2018
Posts: 21
Location: International Falls, MN
Default 2007 F5 LXR new to me

Just picked up an end of season deal to have a spare machine. Isn't perfect but actually pretty decent for the 1500.00 I spent on it. Typical couple rust spots on A arms and such but otherwise body/seat is pretty decent. Starts right up.. Odometer says 6500 miles but owner said he thought it had a rebuild buy original owner. I checked both cylinders and they are about 118 psi each which seems a little lower but they are identical at 118. Cheap Oreilly gauge could be wrong too. Leads me to think no rebuild but not an issue for me anyways. He told me issues were a very small oil seap around oil tank level switch and I need skis which I could see right away. Also said top speed on the lake was 75 mph which is what I see others are near as well. Its curently getting a new gas tank due to recall. Anything on this 07 that I should be keeping an eye on besides the usual? Clutches seemed nice and tight. He did say this past season he had to bring it in to get injectors cleaned they were sticky but issue is resolved I guess.
ewhitefo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2019, 12:43 PM   #2 (permalink)
Advanced Member
 
electricjohn's Avatar
 
Join Date: Nov 2013
Posts: 44
Current Sled(s): 2007 f5
Previous Sled(s): 1970 bolens 290cc
Location: woods tavern, NJ & adirondack, NY
Favorite Riding Area: Essex and Warren county NY
Age: 61
Riding Since: 2008
Default

Reverse actuator on the DD stops working and front suspension links fall off. 5" long bolts solve the link issue.
__________________
the older I get, the better I was.
electricjohn is offline   Reply With Quote
Old 04-16-2019, 12:54 PM   #3 (permalink)
Member
 
Join Date: Mar 2018
Posts: 21
Location: International Falls, MN
Default

Quote:
Originally Posted by electricjohn View Post
Reverse actuator on the DD stops working and front suspension links fall off. 5" long bolts solve the link issue.



Which end? I assume you mean the A-arms come loose?
ewhitefo is offline   Reply With Quote
 
Old 04-16-2019, 07:41 PM   #4 (permalink)
Super Advanced Member
 
Boom2's Avatar
 
Join Date: Dec 2013
Posts: 1,415
Current Sled(s): 2018 XF 800 High Country Lt 2011 Z1 turbo LTD
Previous Sled(s): Too many to list
Location: West Quebec
Favorite Riding Area: Quebec
18-19 Mileage 3800
17-18 Mileage: 2600
16-17 Mileage: 2400
15-16 Mileage: 2800
Age: 66
Riding Since: 66
Default

No it's the sway bar connection. The black plastic adapter can slide off the end of the attachment bar. Their are different methods to stop this from happening. Some just drilled a small hole through the bar and slid a cotter pin in to hold it on. They are a very nice trail sled, ride nice, dependable and easy to work on yourself. Probably need to go with some type off antidarting runner. They have a tendency to dart with single runners.
Boom2 is offline   Reply With Quote
Old 04-17-2019, 02:45 PM   #5 (permalink)
Member
 
Join Date: Mar 2018
Posts: 21
Location: International Falls, MN
Default

Quote:
Originally Posted by Boom2 View Post
No it's the sway bar connection. The black plastic adapter can slide off the end of the attachment bar. Their are different methods to stop this from happening. Some just drilled a small hole through the bar and slid a cotter pin in to hold it on. They are a very nice trail sled, ride nice, dependable and easy to work on yourself. Probably need to go with some type off antidarting runner. They have a tendency to dart with single runners.

Aaah, that answers a question I had, black electricians tape and small tie straps on the ends of sway bar.
ewhitefo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using 2009 front shocks on 2007 Dragon RMK? alaska_lanche IQ chassis 0 03-14-2018 07:57 AM
2007 IQR with 600HO, 2003 PERC CDI - what wiring do I need? Deephaven 440/race/modified 16 08-08-2017 10:41 PM
Is there a difference between a 2007 m1000 driven clutch and a 2009 driven clutch? bertrenolds XFire 136"-141"/Mtn. Cat/M-series 0 05-02-2017 04:32 PM


All times are GMT -4. The time now is 10:43 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.