Fuel tank recall on 07-09 twin spar sleds - Page 7 - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 03-12-2019, 04:12 PM   #61 (permalink)
Advanced Member
 
Join Date: Jan 2018
Posts: 52
Location: Northern Michigan
Default

I bought my F10 in summer of 2017 I checked with the dealer they said the recall had been done. First time i planned on riding i filled the tank the night before with a gas can, came out next morning to a puddle under sled. Called my local dealer, he said it showed the recall had been done but was most likely the collar fix they had. He ordered a new tank and installed, no cost to me whatsoever. I lost the cool flipper style cap was the only downside.
AftonJay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-18-2020, 11:47 AM   #62 (permalink)
Member
 
Join Date: Jan 2007
Posts: 15
Current Sled(s): 2009 TZ1 Turbo LXR LE
Previous Sled(s): 2007 Z1 Jag, 1999 Formula III 700, 1985 Phazer, 1979 Cobra
Location: Greely
Default

I just received one for the TZ1 and one for the Jag Z1. I started on the TZ1 first ,pulled the fuel pump assembly out but for the life of me i cannot get it to go into the new tank. I can just get it to the point where the o-ring is in but it will not go any further. Any movement and it pops itself right back out. It is almost like the inner diameter of the new tank is a hair smaller. Anyone have any tips?
Pipedope is offline   Reply With Quote
Old 01-19-2020, 05:22 PM   #63 (permalink)
Super Moderator
 
zr sled head's Avatar
 
Join Date: Dec 2002
Posts: 12,779
Location: Toronto.
Riding Since: 1861
Default

Are you using a new O'ring?
If yes, try smear of white lithium grease plus a second set of hands.
zr sled head is offline   Reply With Quote
 
Old 01-20-2020, 06:49 PM   #64 (permalink)
Member
 
Join Date: Jan 2007
Posts: 15
Current Sled(s): 2009 TZ1 Turbo LXR LE
Previous Sled(s): 2007 Z1 Jag, 1999 Formula III 700, 1985 Phazer, 1979 Cobra
Location: Greely
Default

It was with the same O-ring, I had already greased it up to get it started.

I received and email from the senior mechanic at my dealer and was told they are harder to go into the new tanks. Once the O-ring is started what they do is a piece of pipe of the same diameter as the pump assembly and tap it in.

So... 3" ABS pipe and it took a bit more than a tap but it seated in a few seconds.

Now I have one more tank to do hopefully no other surprises!
Pipedope is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:31 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.