D&D Torque Arm Install... NEED HELP! - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 10-23-2016, 10:11 PM   #1 (permalink)
Newbie
 
Join Date: Oct 2016
Posts: 2
Location: New York
19-20 Mileage:
18-19 Mileage: 1500
Default D&D Torque Arm Install... NEED HELP!

I went to install the D&D torque arm on my 2007 F8 Sno Pro and the holes would not align... i insalled the bracket that attaches to through the sled to the A-Arm okay, and then installed the bolt through the mount on the engine but then i cannot install the actual torque arm, the engine has to move up or back.

My sled is currently sitting on dollies, one under each ski and one under the track, could that cause the misalignment? How am I supposed to fix the alignment issue to install the torque bar??

Any Help would be much appreciated!
Duog69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-23-2016, 11:03 PM   #2 (permalink)
Super Moderator
 
zr sled head's Avatar
 
Join Date: Dec 2002
Posts: 12,568
Location: Toronto.
Riding Since: 1861
Default

Did you lengthen or shorten as required?
I would suggest final adjustment should be done with the sled slitting flat on the ground without front or rear elevated.
zr sled head is offline   Reply With Quote
Old 10-23-2016, 11:04 PM   #3 (permalink)
Super Moderator
 
zr sled head's Avatar
 
Join Date: Dec 2002
Posts: 12,568
Location: Toronto.
Riding Since: 1861
Default

Looks like this one?

https://www.hardcoresledder.com/forum...orque-arm.html
zr sled head is offline   Reply With Quote
 
Old 10-24-2016, 01:05 PM   #4 (permalink)
Super Advanced Member
 
mnzl500's Avatar
 
Join Date: Jan 2010
Posts: 175
Current Sled(s): 14 XF 8000 LTD; 71 Panther
Previous Sled(s): 08 F1000; 98 ZL 500
Location: Savage, MN
Favorite Riding Area: snowy
17-18 Mileage: 900
16-17 Mileage: 300
Default

Quote:
Originally Posted by Duog69 View Post
I went to install the D&D torque arm on my 2007 F8 Sno Pro and the holes would not align... i insalled the bracket that attaches to through the sled to the A-Arm okay, and then installed the bolt through the mount on the engine but then i cannot install the actual torque arm, the engine has to move up or back.

My sled is currently sitting on dollies, one under each ski and one under the track, could that cause the misalignment? How am I supposed to fix the alignment issue to install the torque bar??

Any Help would be much appreciated!
Were you able to just recently purchase this? Sorry looking for one and having trouble finding one. Thanks
mnzl500 is offline   Reply With Quote
Old 10-24-2016, 01:31 PM   #5 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,293
Current Sled(s): "Agri-vator"
Default

How much does it lack of aligning, With the rod adjusted all the way short as stated above?
stronger800 is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:21 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.