Jetting for 2010 Iqr 600 - Page 2 - HCS Snowmobile Forums

440/race/modified This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-27-2018, 03:23 PM   #11 (permalink)
Super Advanced Member
 
Drumerjb's Avatar
 
Join Date: Jan 2012
Posts: 2,788
Current Sled(s): 14 Indy 800/ 05 800 XC
Previous Sled(s): 72 340 Rupp Nitro,73 440 Nitro,75 440 FA,02 Edge 500
Location: Jackson,Wi.
Favorite Riding Area: Any where in WI.
18-19 Mileage 1500
17-18 Mileage: 2300
16-17 Mileage: 2100
15-16 Mileage: 875
Age: 58
Riding Since: 1968
Default

Quote:
Originally Posted by Johnny104104 View Post
Yea it gurgles in the midrange. I know it’s a race sled like everyone keeps saying but I wouldn’t or couldn’t hit 20 ft double with it like this it wouldn’t even be fair to race it it’d be so hard to even get around the track like this.
Did you try dropping the needles 1 step?
Drumerjb is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2018, 10:50 PM   #12 (permalink)
Newbie
 
Join Date: Feb 2018
Posts: 5
Current Sled(s): 2010 iqr 600
Location: Bennington Vermont
Favorite Riding Area: Woodford vt
Age: 30
Riding Since: 1990
Default

Yea I did but I’m going to try it again and see we finally got snow again ! Lol I let you know thanks !
Johnny104104 is offline   Reply With Quote
Old 03-08-2018, 08:11 PM   #13 (permalink)
Newbie
 
Join Date: Feb 2018
Posts: 5
Current Sled(s): 2010 iqr 600
Location: Bennington Vermont
Favorite Riding Area: Woodford vt
Age: 30
Riding Since: 1990
Default

I dropped the needle one spot and it’s awesome now good all the way threw makes way more fun to ride now lol. But I am mixing 32:1 now instead of 40:1 amsoil intercepter just because my clip is all the way at the top now.
Johnny104104 is offline   Reply With Quote
 
Old 02-01-2019, 10:31 PM   #14 (permalink)
Newbie
 
Join Date: Aug 2018
Posts: 4
Default

I have a 2014 iqr 600 the only the I've changed was mains are 420s and timing at g sled runs strong at launch ,mid and top end .no problem's so far
Dccarmen74 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:47 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.