Z1 issue - HCS Snowmobile Forums

4 Stroke Cats 1100 Turbo / 1100NA / Z1 Turbo / Z1 / T660/ This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 01-20-2020, 02:58 PM   #1 (permalink)
Super Advanced Member
 
Join Date: Sep 2016
Posts: 156
Default Z1 issue

08 na 1100 started it beginning of season and it barely ran fouling a plug out.. put new plugs in and it ran fine, put new fuel in and drove 20-30 miles a no problem. Went to start it again a couple days later and it won't start it's doing the same thing.. thoughts?
jminor1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-20-2020, 08:51 PM   #2 (permalink)
Super Advanced Member
 
pineluretom's Avatar
 
Join Date: Sep 2011
Posts: 103
Default

Are you letting it warm up before taking off? They are notorious for fouling plugs if not warmed up. Even mentioned in the Owners Manual.
pineluretom is offline   Reply With Quote
Old 01-20-2020, 11:46 PM   #3 (permalink)
Super Advanced Member
 
Join Date: Sep 2016
Posts: 156
Default

Quote:
Originally Posted by pineluretom View Post
Are you letting it warm up before taking off? They are notorious for fouling plugs if not warmed up. Even mentioned in the Owners Manual.
Yes 100%
jminor1 is offline   Reply With Quote
 
Old 01-22-2020, 11:22 AM   #4 (permalink)
Super Advanced Member
 
Join Date: Sep 2016
Posts: 156
Default

He did say it was revving a bit when turning so I wonder if his tors switch is not allowing it to fire..??
jminor1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:36 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.