Any Help on this?? 1997 500 classic - Page 2 - HCS Snowmobile Forums

Trail/Classic/XLT This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree4Likes
Reply
 
LinkBack Thread Tools
Old 11-14-2019, 09:41 PM   #11 (permalink)
Member
 
Join Date: Nov 2019
Posts: 14
Current Sled(s): 94 XLT SP
Previous Sled(s): 2x92 Indy 500s
Location: NE Oregon
Favorite Riding Area: Blue Mountains
19-20 Mileage: none yet
18-19 Mileage: none
17-18 Mileage: none
16-17 Mileage: none
Age: 52
Riding Since: 1974
Default

A little blurry, but if you look you can see all 3 of the one way valves hanging down. On mine, they just end at the valve, there is no extra hose on it. Might be right, might not be? But that's how it was before I replaced all lines.
Attached Thumbnails
Click image for larger version

Name:	carbs.jpg
Views:	8
Size:	83.8 KB
ID:	2062598  
Badger likes this.
cat5752 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:10 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.