Anybody good with belt numbers? - Page 5 - HCS Snowmobile Forums

XC This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 04-25-2015, 10:11 PM   #41 (permalink)
Newbie
 
Join Date: Apr 2015
Posts: 5
Location: fairbanks alaska
Default

Haha dumb phone! Does not.
MEGASNOWMACHINE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-25-2015, 10:14 PM   #42 (permalink)
Super Advanced Member
 
sleeping_dragon's Avatar
 
Join Date: Apr 2009
Posts: 6,010
Current Sled(s): 2012 800 iqr,13 800 sb,fusion 900 triple
Previous Sled(s): pro-x/xcr 800 engine,xc 800 triple,storms,ultras,650s,
Location: West Bend WI
Favorite Riding Area: western U.P/northern WI
Age: 42
Riding Since: 1974
Default

Quote:
Originally Posted by OldPolaris View Post
Yes , I got that , you said you had been waiting to hear back on the compounds , that is what I am wondering about . I know dimension wise this will fit my machine , I am wondering is it practical to use on my machine , an '04 xcsp 600 or is a bit on the stiff side for my clutches to be trying to grab .
It should work fine if its a little harder.The newer belts like to"warm up"a little on higher hp applications or they will slip a little.


Sent from Snowmobile.com Free App
sleeping_dragon is offline   Reply With Quote
Old 04-25-2015, 10:15 PM   #43 (permalink)
Newbie
 
Join Date: Apr 2015
Posts: 5
Location: fairbanks alaska
Default

I'll take a look!! Mabey...
MEGASNOWMACHINE is offline   Reply With Quote
 
Old 04-25-2015, 10:34 PM   #44 (permalink)
Newbie
 
Join Date: Apr 2015
Posts: 5
Location: fairbanks alaska
Default

well I took the bolts out and then went back to the correct widthbut it does not seem like the bolt is long enough my clutch popped off while I was riding it haha
MEGASNOWMACHINE is offline   Reply With Quote
Old 04-26-2015, 08:01 AM   #45 (permalink)
Super Advanced Member
 
patrioticinnovations's Avatar
 
Join Date: Sep 2005
Posts: 14,840
Current Sled(s): 2015 AXYS Pr-S SB Ann 800, 2019 Indy 850.
Previous Sled(s): 2003 XCR 1100, 2000 XCR 800, 2005 Redline Revolt 800.
Location: SE Lower Michigan
Favorite Riding Area: Cadillac, Gaylord
19-20 Mileage:
18-19 Mileage: 849 so far
17-18 Mileage: 1280
16-17 Mileage: 1115
Riding Since: 1982
Default

Quote:
Originally Posted by MEGASNOWMACHINE View Post
well I took the bolts out and then went back to the correct widthbut it does not seem like the bolt is long enough my clutch popped off while I was riding it haha
Oh boy. How the heck does a too short bolt push the outer cover of the clutch in .25"?

I think you must be using the wrong washer. The proper washer must go inside the cover, but clamp on the clutch shaft. I believe you need just a lock washer. Then tighten the bolt to 50 ft lbs torque. Make sure clutch bore and crank taper are nice and clean first. No oil or anti-seize between them.
patrioticinnovations is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:57 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.