2007 sdi 600 dies intermitently - HCS Snowmobile Forums

REV Chassis This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-14-2012, 06:57 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2012
Posts: 7
Default 2007 sdi 600 dies intermitently

my 2007 sdi 600 will run and then it dies and sometimes won't start back up. It may run for an hour on the trail the it dies and the gauges get stuck half way. It will usually start back up an run again. Anyone else had this? thanks Matt3552
matt3552 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2012, 07:31 PM   #2 (permalink)
Super Advanced Member
 
AkS144's Avatar
 
Join Date: Feb 2012
Posts: 2,190
Current Sled(s): 2008 Ski Doo Summit 600 HO SDI
Location: Alaska
Favorite Riding Area: The Mountains
Default

I've heard there's a relay that can cause some crazy shit to happen to your sled, you might want to try and swap that out. I think it's inside that fuse box but don't hold me to it.
AkS144 is offline   Reply With Quote
Old 02-15-2012, 12:07 PM   #3 (permalink)
Advanced Member
 
Join Date: Apr 2007
Posts: 86
Location: WINNIPEG
Default

IF its anything like the '06's,there's a wire thats Zipped tied together near a harness under or behind the airbox somewhere thats common for getting worn thru or breaking. You wont see it unless you remove all that crap blocking it. I've never seen it myself but it was a problem on ours. Check the dealers to see if that could be it 'cause it sounds like an electrical issue.
denny4 is offline   Reply With Quote
 
Old 02-15-2012, 01:11 PM   #4 (permalink)
Super Advanced Member
 
catrules2000's Avatar
 
Join Date: Aug 2004
Posts: 2,195
Current Sled(s): 162" 2005 F-7/2007 Summit SDI
Previous Sled(s): T-Cat, ZR, EXT, V-Max
Location: New Bremen, Ohio
Favorite Riding Area: Starvation Lake & Rabbit Ears
18-19 Mileage 535
17-18 Mileage: 511
16-17 Mileage: 930
15-16 Mileage: 985
Age: 43
Riding Since: 1980
Default

Quote:
Originally Posted by matt3552 View Post
my 2007 sdi 600 will run and then it dies and sometimes won't start back up. It may run for an hour on the trail the it dies and the gauges get stuck half way. It will usually start back up an run again. Anyone else had this? thanks Matt3552
I had this happen on my 07' 600 SDI Summit one time. 20-25 miles after lunch and the thing just shut off going down the trail. Thought I locked it up. Pulled the DESS, plugged it back in and the thing started right up. First and only time this has happened in 3200 Miles
catrules2000 is offline   Reply With Quote
Old 02-17-2012, 05:00 PM   #5 (permalink)
Super Advanced Member
 
evilvtwin's Avatar
 
Join Date: Nov 2003
Posts: 1,398
Current Sled(s): Two 2012 TNT 600 ACE'S
Previous Sled(s): 07 600 Blizzard, 07 MXZ 550X
Location: Seabrook, NH
Favorite Riding Area: Jackman Maine
18-19 Mileage 0000
17-18 Mileage: 1100
16-17 Mileage: 2000
15-16 Mileage: 2300
Age: 58
Riding Since: 1975
Default

Swap relays.
__________________
Members for the 2017/2018 season:
Jackman: Border Riders Sportsmans Club
West Forks: Coburn Summit Riders
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Website and Membership Officer for CSR)


Our Home Away From Home:
Spruce Meadow Cabins 207-668-4000
evilvtwin is offline   Reply With Quote
Old 03-01-2012, 05:28 PM   #6 (permalink)
Super Advanced Member
 
evilvtwin's Avatar
 
Join Date: Nov 2003
Posts: 1,398
Current Sled(s): Two 2012 TNT 600 ACE'S
Previous Sled(s): 07 600 Blizzard, 07 MXZ 550X
Location: Seabrook, NH
Favorite Riding Area: Jackman Maine
18-19 Mileage 0000
17-18 Mileage: 1100
16-17 Mileage: 2000
15-16 Mileage: 2300
Age: 58
Riding Since: 1975
Default

Once again my SDI stalled once while idling and once on the trail last Sunday. Replaced the relay and rode close to 600 miles. Left on Tuesday without any issues.
Matt how did you make out with your problem?
__________________
Members for the 2017/2018 season:
Jackman: Border Riders Sportsmans Club
West Forks: Coburn Summit Riders
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Website and Membership Officer for CSR)


Our Home Away From Home:
Spruce Meadow Cabins 207-668-4000
evilvtwin is offline   Reply With Quote
Old 03-16-2012, 10:59 AM   #7 (permalink)
Super Advanced Member
 
catrules2000's Avatar
 
Join Date: Aug 2004
Posts: 2,195
Current Sled(s): 162" 2005 F-7/2007 Summit SDI
Previous Sled(s): T-Cat, ZR, EXT, V-Max
Location: New Bremen, Ohio
Favorite Riding Area: Starvation Lake & Rabbit Ears
18-19 Mileage 535
17-18 Mileage: 511
16-17 Mileage: 930
15-16 Mileage: 985
Age: 43
Riding Since: 1980
Default

Mine did it 2 weeks ago again. Just riding down the trail and died. Started back up and rode a couple hundred more miles with no issues......weird
catrules2000 is offline   Reply With Quote
Old 03-29-2012, 05:44 PM   #8 (permalink)
Super Advanced Member
 
AkS144's Avatar
 
Join Date: Feb 2012
Posts: 2,190
Current Sled(s): 2008 Ski Doo Summit 600 HO SDI
Location: Alaska
Favorite Riding Area: The Mountains
Default

Sounds like something is loose. I had mine die on me when I rolled it off the side of a hill. It was still running when I got to it but it eventually quit and would not restart at all. After much troubleshooting I found the red wire going from the battery to the capacitor had broken. Check all that wiring down there and make sure everything is good and tight.
AkS144 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:48 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.