2009 600 engine lock up - HCS Snowmobile Forums

REV Chassis This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 12-30-2019, 06:23 PM   #1 (permalink)
Member
 
Join Date: Feb 2014
Posts: 14
Current Sled(s): 2011 switchback assault 800
Previous Sled(s): 2002 mxzx 600 144
Location: Lakeville man
Favorite Riding Area: Ely mn
17-18 Mileage: 600
16-17 Mileage: 500
Age: 37
Riding Since: 1988
Default 2009 600 engine lock up

When engine warms up it locks up suddenly. Have to rotate the engine backwards to free it.
Nigel ess is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-30-2019, 06:26 PM   #2 (permalink)
Member
 
Join Date: Feb 2014
Posts: 14
Current Sled(s): 2011 switchback assault 800
Previous Sled(s): 2002 mxzx 600 144
Location: Lakeville man
Favorite Riding Area: Ely mn
17-18 Mileage: 600
16-17 Mileage: 500
Age: 37
Riding Since: 1988
Default

Only has 900 miles on it. Something must be getting jammed. Rebuilt lower end. No change. Could rings be catching ports
Nigel ess is offline   Reply With Quote
Old 12-30-2019, 09:07 PM   #3 (permalink)
Super Moderator
 
zr sled head's Avatar
 
Join Date: Dec 2002
Posts: 12,776
Location: Toronto.
Riding Since: 1861
Default

Did you see anything in the bottom end to have been causing it? Positive all crank bearings ok?
zr sled head is online now   Reply With Quote
 
Old 12-30-2019, 09:11 PM   #4 (permalink)
Super Advanced Member
 
b.lee's Avatar
 
Join Date: Mar 2006
Posts: 4,865
Current Sled(s): 14 Gade Etec 800
Previous Sled(s): 09 Gade Etec 600
Location: Lapeer County, MI
Favorite Riding Area: Rose City Mio Luzerne, MI
19-20 Mileage: 450
18-19 Mileage: 1,001
17-18 Mileage: 1,856
16-17 Mileage: 1,362
Age: 32
Riding Since: 1998
Default

Locks up at idle? or while riding?

If at idle, I'd take the top end off. I'm guessing a damaged piston / cylinder.
Most likely crank seal causing lean condition on one cylinder.
__________________
14 Renegade Etec 800
09 Renegade Etec 600
12 2500 Cummins Mega Laramie - EFI Live

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
b.lee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:11 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.