Clutching - HCS Snowmobile Forums

XFire 128/Firecat(03-06 & 09-?) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 01-06-2020, 09:03 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2017
Posts: 1
Current Sled(s): 2019 ZR6000RR, 2006 Sabercat 700
Location: Charlotte, Michigan
19-20 Mileage: 0
18-19 Mileage: 1700
17-18 Mileage: 1200
16-17 Mileage: ?
Age: 30
Riding Since: 1998
Default

So, i bought a speedwerx clutch kit for my 2006 Sabercat 700. After install clutch engagement is bang on to the kit spec and engagement is definitely harsher than stock. The kit seems to run great except for when you are at a dead stop and just hammer it. The belt sucks down into the secondary and slips like crazy, to the point where you launch and then lose all forward movement, like the secondary is shifting out too fast. I tried similar to stock deflection and even went with less deflection to try and compensate. Still the same results. Now this is if you are on some hard pack or ice where the track hooks up good. Otherwise its fine. I contacted speedwerx and we verified all the parts were correct, they then sent me a different helix to try. At the time the season had ended and i didn't feel like messing with it anymore. Before i dig into it this season does any clutch gurus have any other input as to what could be the issue?

Last edited by JHart11; 01-06-2020 at 09:06 PM.
JHart11 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-08-2020, 06:45 PM   #2 (permalink)
Super Advanced Member
 
Join Date: Oct 2007
Posts: 812
Current Sled(s): 2014 XF8000 Limited , 05 600 sabercat
Previous Sled(s): 700 wildcat ,1980 eltigre
Favorite Riding Area: Western Newfoundland
Age: 51
Riding Since: 1974
Default

sabercat so chain case with torsional secondary? ...not enough spring pressure ...cat green spring is hard to beat ..what hole is the spring in on the secondary ?
__________________
teaser61
teaser61 is offline   Reply With Quote
Old 01-08-2020, 11:21 PM   #3 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,852
Current Sled(s): "Agri-vator"
Default

Secondary Spring installed wrong (as in the spring twisted the wrong way when installed)
stronger800 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:21 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.