Fuel issue - HCS Snowmobile Forums

XFire 128/Firecat(03-06 & 09-?) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 12-19-2019, 06:27 PM   #1 (permalink)
Super Advanced Member
 
snochopper's Avatar
 
Join Date: Mar 2004
Posts: 5,068
Current Sled(s): 2017 ZR9000 Limited
Previous Sled(s): 77 ElTigre 500 FA
Location: Upstate NY
Favorite Riding Area: Up North
Age: 60
Riding Since: 1972
Default Fuel issue

Firecat/Sabercat experts, seems a long time ago I read something about the fuel pickups in these tanks, are they all "smartvalves"? Friend has a 600 carb that he says runs perfect till he gets to around 45-50 and that's all shes got. I serviced it for him last season, cleaned the carbs, clutches seemed ok, new belt, all I can think of (going by his description) is throttle switch or fuel pickup, any thoughts? 2200 miles, like new.
snochopper is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-20-2019, 12:08 PM   #2 (permalink)
Super Advanced Member
 
STEVEJR's Avatar
 
Join Date: Feb 2003
Posts: 810
Current Sled(s): [2] 03 zr900 [1] 03 f7 [1] 05 f7
Previous Sled(s): baby sitter of many kitties
Location: wny
Riding Since: 1971
Default

Do the carb models even have smart valves?
STEVEJR is online now   Reply With Quote
Old 12-20-2019, 12:17 PM   #3 (permalink)
Super Advanced Member
 
TURBOBLUE's Avatar
 
Join Date: Apr 2010
Posts: 1,885
Location: CENTRAL WISCONSIN
Default

Carb motors dont have smart valves. There should be a filter by the chain case
TURBOBLUE is offline   Reply With Quote
Old 12-20-2019, 01:18 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,852
Current Sled(s): "Agri-vator"
Default

Exhaust valve cable rust up and stick/break during the off season? I recently took one apart for a buddy (Much much newer sled) one valve stuck closed, other stuck 85% open, one cable briken, one snapped. And it was running "down on power".
stronger800 is online now   Reply With Quote
Old 12-20-2019, 06:47 PM   #5 (permalink)
Super Advanced Member
 
snochopper's Avatar
 
Join Date: Mar 2004
Posts: 5,068
Current Sled(s): 2017 ZR9000 Limited
Previous Sled(s): 77 ElTigre 500 FA
Location: Upstate NY
Favorite Riding Area: Up North
Age: 60
Riding Since: 1972
Default

Quote:
Originally Posted by TURBOBLUE View Post
Carb motors dont have smart valves. There should be a filter by the chain case
I didn't think they would have them in a carb sled, never dove too deep into those "skinny ass" sleds.,, I will have him check the filter and as Stronger mentioned, maybe its a combo cluster. Its tough trying to diagnose from a distance.
snochopper is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:08 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.