Cfr1000 more traction - HCS Snowmobile Forums

XFire 128/Firecat(03-06 & 09-?) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 11-10-2019, 11:25 AM   #1 (permalink)
Member
 
Join Date: Jan 2018
Posts: 15
Location: Northern michigan
Default Cfr1000 more traction

I've extended track to 136 with a 1.5 intense, no studs.
Rebuilt suspension.
Front strap all the way loose
Coupling blocks out
Sway bar out
Slp muffler and Y
Bmp torsional conversion

Still dont have the traction I want in powder or even wet snow. It doesn't stand up easily either, I have to ride the back of the boards, so maybe it isn't weight transfering enough.

What can i do? I'm just blowing the track off.
Leadneck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2019, 10:03 PM   #2 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,868
Current Sled(s): "Agri-vator"
Default

Rail extensions on a stock skid? Tighten front skid spring, loosen rear springs,.....put 2" studs in it.
stronger800 is offline   Reply With Quote
Old 11-12-2019, 01:55 PM   #3 (permalink)
Member
 
Join Date: Jan 2018
Posts: 15
Location: Northern michigan
Default

Yes, rail extensions. I'm not sure the intense is a studdable track....
Leadneck is offline   Reply With Quote
Old 11-12-2019, 09:42 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 19,868
Current Sled(s): "Agri-vator"
Default

Sure it is. Sure you have the suspension and suspension arms all mounted in the correct holes?
stronger800 is offline   Reply With Quote
Old 01-02-2020, 07:31 PM   #5 (permalink)
Member
 
Join Date: Jan 2018
Posts: 15
Location: Northern michigan
Default

I'm fairly sure. I had skid all apart and it seemed like it wouldn't go any other way.
Leadneck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:17 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.