Dirty Chaincase Fluid - HCS Snowmobile Forums

Switchback Assault/SKS/RMK (AXYS Platform) This is a brand-specific forumand a 100% NO BASH Zone. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree2Likes
  • 1 Post By just-pinch-it
  • 1 Post By northstarrick
Reply
 
LinkBack Thread Tools
Old 03-26-2020, 08:48 AM   #1 (permalink)
Advanced Member
 
Join Date: Apr 2008
Posts: 39
Current Sled(s): 2020 SBA 850
Location: Stillwater, MN
19-20 Mileage: 1505
18-19 Mileage: 900
Age: 41
Riding Since: 1990
Default Dirty Chaincase Fluid

Just changed chaincase fluid for second time on 2020 SBA 850 at 1500 miles. When draining fluid it was grey and black that where totally separate in the pan. Took cover off and cleaned everything out. Everything looked good, adjusted chain and resembled. Would that black fluid be from a seal? Kinda concerned because i have had the intermittent brake go from barely need to pull leaver to half pull. Rotor and pads looked good. Always ran Polaris SCL. Any ideas on why i have such dirty oil? Was second change. first was at 800 miles just cracking bottom method.
brandxrider is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2020, 08:52 AM   #2 (permalink)
Super Moderator
 
XCR1250's Avatar
 
Join Date: Oct 2005
Posts: 36,182
Current Sled(s): XCR 800
Previous Sled(s): O.M. 1000, 700 Heavy Mod, 700 IS XCR 1253, XC1214, P.S.700
Location: Sawyer county Wisconsin
Favorite Riding Area: N.W. Wisconsin
Riding Since: 1959
Default

Normal wear particles.
XCR1250 is offline   Reply With Quote
Old 03-26-2020, 10:04 AM   #3 (permalink)
Super Advanced Member
 
just-pinch-it's Avatar
 
Join Date: Mar 2005
Posts: 1,908
Current Sled(s): Waiting...
Previous Sled(s): Pro-R SB 800, 700 dragon, Pro-XR, XCR, Storm, XLT, Trail
Location: IN
Favorite Riding Area: MI
Riding Since: 86
Default

Most is from tensioner. You could pull a magnet through the fluid to see how much is metallic. You will find very little.
northstarrick likes this.
just-pinch-it is offline   Reply With Quote
 
Old 03-26-2020, 03:50 PM   #4 (permalink)
HCS Advertiser
 
northstarrick's Avatar
 
Join Date: Mar 2011
Posts: 9,995
Default

the vespal (plastic ) chain tensioner wears a lot. this is the main reason the oil looks like shit. we replace all with the IQR roller tensioner. just changed my oil looked like new. amsoil chain case oil. we don't like scl it always looks like water is in it? is the scl water based? no water in the amsoil chain case oil. and it looks clean so you can tell if it's dirty or something might be wrong?
Sledtuner360 likes this.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Northstar Performance Products
Stage 1,2,3 clutch kits
Oil tank vent kits
Doo T-Stat bypass kits
Rush/Axys A-Arm bushing kits
550 fan upgrade kit

Our products have been race tested and proven all across North America!

Authorized dealer for
SLP
RK-Tek
WPS
US Chrome
Thunder Products
Automatic Distributors
Venom/Team Ind.
Redline Oil
Klotz Racing Synthetics
K100
northstarrick is offline   Reply With Quote
Old 03-26-2020, 04:04 PM   #5 (permalink)
Advanced Member
 
Join Date: Apr 2008
Posts: 39
Current Sled(s): 2020 SBA 850
Location: Stillwater, MN
19-20 Mileage: 1505
18-19 Mileage: 900
Age: 41
Riding Since: 1990
Default

Ya ill defiantly be switching over to the iqr roller next year. Just got it all ready for summer storage. Called dealer today to bring it in for new 850 reflash and check out the brake issue and they said they might not be open after tomorrow and i wouldn't be able to get at it so putting it off till fall.
brandxrider is offline   Reply With Quote
Old 03-26-2020, 06:54 PM   #6 (permalink)
Super Advanced Member
 
-dw-'s Avatar
 
Join Date: Dec 2005
Posts: 3,169
Current Sled(s): 13 Indy, 01 600xcsp, 00 600xcsp
Previous Sled(s): 3 arcticcraps
Location: Central Mn
Favorite Riding Area: from my house
Age: 37
Riding Since: 85
Default

Quote:
Originally Posted by just-pinch-it View Post
Most is from tensioner. You could pull a magnet through the fluid to see how much is metallic. You will find very little.
Dont see a problem. Less metal to metal the better. First yr with my Indy I noticed the black fluid. Changed it several times. Now I dont care.
__________________
Quote:
Originally Posted by krom
you are wrong
-dw- is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:50 AM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.