Seat Issue Polaris Titan - HCS Snowmobile Forums

Switchback Assault/SKS/RMK (AXYS Platform) This is a brand-specific forumand a 100% NO BASH Zone. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Like Tree2Likes
Reply
 
LinkBack Thread Tools
Old 12-28-2017, 05:04 PM   #1 (permalink)
Advanced Member
 
Join Date: Oct 2017
Posts: 56
Current Sled(s): 2019 Ski Doo Freeride 154
Location: Sault Ste Marie, ON, Can
Default Seat Issue Polaris Titan

Just wanted to see if anybody has heard of / or has dealt with this issue before.

110mi on my Titan XC and the seat has fallen off 8x. It has come off on trail and off trail. The rear post that affixes the seat has a ton of metal wear. Sorry I don't have a picture of it.

I took it to the local dealer and they tried a new seat and it was no help. The guy thinks that maybe the post isn't adjusted to the right height? It is in the shop for them to try this.

I may be jumping the gun, and it is nothing more than an adjustment issue but I wanted to see if other Titan users were experiencing the same problem. I fear that it may be a design issue....not sure what I can/should do if this happens again.

Thanks guys.
BB
BirdBlaster is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2018, 03:04 PM   #2 (permalink)
Newbie
 
Hanhis's Avatar
 
Join Date: Jan 2012
Posts: 1
Current Sled(s): Polaris Dragon 700 HO CFI 2007
Location: Finland
Age: 39
Riding Since: 1987
Default

I have now 800kilometers (thats about 500miles) on my titan adventure and seat has not fallen off. And i have been riding quite hard on trails (and our trails are hardly ever groomed so you really need suspension). I have also ridden about 600 kilometers with a demo xc, which had nearly 2000kilometers on the clock and no problems with seat on that one. So you have some issue with the seat.
Hanhis is offline   Reply With Quote
Old 02-25-2018, 07:26 PM   #3 (permalink)
Member
 
Join Date: Jan 2014
Posts: 16
Current Sled(s): 2006 p0laris 340 touring
Riding Since: 1985
Default

Iíve had zero issues both my seat , 200+ kms, titan adventure
goosemanx is offline   Reply With Quote
 
Old 02-25-2018, 09:25 PM   #4 (permalink)
Advanced Member
 
Join Date: Oct 2017
Posts: 56
Current Sled(s): 2019 Ski Doo Freeride 154
Location: Sault Ste Marie, ON, Can
Default

all was sorted out with dealer. They just adjusted the rear post.

I've since sold it...so don't know if this is an ongoing issue for the new owner
BirdBlaster is offline   Reply With Quote
Old 01-12-2019, 08:09 AM   #5 (permalink)
Newbie
 
Join Date: Mar 2011
Posts: 5
Default

Hey Guy’s, have a 18 Titan Adventure, love the sled but really noisy and vibration at low speed, 20 to 60 km. How’s yours.
GTXMike is offline   Reply With Quote
Old 01-12-2019, 10:07 AM   #6 (permalink)
Super Advanced Member
 
ivar's Avatar
 
Join Date: Apr 2004
Posts: 16,702
Current Sled(s): 2019 SBA 850
Previous Sled(s): too many to choose from
Location: Spitsbergen / Norway
Default

I rode a demo titan XC last spring, I also noticed a fair amount of track noise at lower speeds. I suspect that 1.8" track may be to blame...?

As for the seat, got some buddies that got 2k+ miles , one of them works as a guide and probably got lots more, Never heard of seat trouble.
__________________
2019 SBA 850,2015 600 Adventure (int'l)
09 Doo 1200 GTX, 02 XC800 / 00 XCR800 - Pro-X rear skid, 99 XC700SP
RIP: 800SBA, 02 XC800, 99 SKS700, 97 XLT SKS
ivar is offline   Reply With Quote
Old 01-25-2019, 09:44 PM   #7 (permalink)
Newbie
 
Join Date: Jan 2019
Posts: 1
Default

I just picked up a 2018 brand new non current. Put on less then 60 miles and brought it back. Vibrates bad on the feet and the track noise is enough to drive you insane. Got it back and not much better. Traded my 2018 switchback for this?? Not impressed so far. Thinking of bringing it back in again. Any thoughts?? Track is aligned perfectly
Whiss1 is offline   Reply With Quote
Old 01-26-2019, 01:08 AM   #8 (permalink)
Advanced Member
 
Join Date: Mar 2018
Posts: 91
Current Sled(s): 2018 SKS 146
Location: SE wisconsin
Favorite Riding Area: W.U.P
17-18 Mileage: 2000
16-17 Mileage: 1780
Age: :(
Riding Since: 1995
Default

its a 155 x 20 track it will make noise.

we demo'd one for a day and at slow speeds on hardpack you can hear the track.

its pretty impossible to get the titan stuck. that 1.8 track is money all around.
slowsi0000 is offline   Reply With Quote
Old 01-26-2019, 01:23 AM   #9 (permalink)
Advanced Member
 
Join Date: Jan 2019
Posts: 43
Current Sled(s): 2019 Titan XC
Location: Newfoundland Canada
Age: 38
Default

Quote:
Originally Posted by Whiss1 View Post
I just picked up a 2018 brand new non current. Put on less then 60 miles and brought it back. Vibrates bad on the feet and the track noise is enough to drive you insane. Got it back and not much better. Traded my 2018 switchback for this?? Not impressed so far. Thinking of bringing it back in again. Any thoughts?? Track is aligned perfectly
I have the 1.8" on mine. Its noisy at low speed for sure...noticeably noisy. The capability of the sled hides this flaw IMO.

As for the seat issue...my seat fits tight. No issues.
lennstang likes this.
NLTitan is offline   Reply With Quote
Old 01-28-2019, 06:54 AM   #10 (permalink)
Member
 
Join Date: Feb 2011
Posts: 12
Default

i own a polaris titan sp . the annoying and embarrassing noise at low speeds comes from the hard plastic cover that sits over the steel racks. the two center bolts for the plastic cover doesnt press down . removing those two bolts and adding rubber washers so that it pushes down the cover will help. i removed the cover completely and cut inch wide strips of thick gasket material , drilled holes for the bolts and siliconed it on the steel racks just so it wont move when i reinstalled the plastic cover. my plastic cover is now separated from the steel. annoying sounds are gone.
NLTitan likes this.
nb-attak is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:10 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.