Td 4 stage v19 boost numbers - Page 4 - HCS Snowmobile Forums

Turbo 4 Stroke This is the section for all the Turbo 4 Stroke talk This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Sponsored by: Evolution Powersports

Reply
 
LinkBack Thread Tools
Old 02-04-2013, 10:26 AM   #31 (permalink)
Super Advanced Member
 
tooofastf7tr's Avatar
 
Join Date: Aug 2005
Posts: 1,294
Location: wpg
Default

The profile drops top rpm..... That's been posted on here many times.
tooofastf7tr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2013, 12:09 PM   #32 (permalink)
Super Advanced Member
 
Jester's Avatar
 
Join Date: Dec 2002
Posts: 4,896
Current Sled(s): 12 F1100 SP turbo Orange, 08 f1000 sp
Previous Sled(s): 06 cf 700 SP, 05 F7sp
Location: Ottawa, Ontario
Favorite Riding Area: Norther Ontario/ Quebec
11-12 Mileage: 1800
10-11 Mileage: 2500
Age: 43
Riding Since: 1969
Default

I had T1's and had the exact problem and using a 5W Dalton now with descent success. Will be changing that shortly with the Bondi fix!

Jester
__________________
Ready for snow wherever it may be!!!!

Jester is offline   Reply With Quote
Old 02-04-2013, 03:22 PM   #33 (permalink)
Super Advanced Member
 
Join Date: Dec 2002
Posts: 921
Current Sled(s): 2012 F1100 Turbo
Previous Sled(s): 2011 800 Etec
Location: Pa
Favorite Riding Area: Qc.
Riding Since: 1990
Default

Quote:
Originally Posted by midwesttcat View Post
Take the secondary clutch off and you can get right to the hose on the plenum.4 clamps. new eco should be 15-15.5# Boost adjust will usually vary the boost up and down if in boost correction.
Which programs are "new eco" ?
pipeman is offline   Reply With Quote
Old 02-04-2013, 05:07 PM   #34 (permalink)
Super Advanced Member
 
welderllj's Avatar
 
Join Date: Feb 2009
Posts: 882
Default

Check bov thats were i having a issue now
Quote:
Quote:
h
welderllj is offline   Reply With Quote
Old 02-04-2013, 06:13 PM   #35 (permalink)
Super Advanced Member
 
Join Date: Nov 2004
Posts: 374
Current Sled(s): 2012 f1100 turbo 50th
Previous Sled(s): 2007 f1200 sno pro
Location: Upstate ny
Age: 50
Default

Pressure tested system today and found no leaks.
Could it be timing/boost adjust because of gas?
black1010 is offline   Reply With Quote
Old 02-04-2013, 06:28 PM   #36 (permalink)
Super Advanced Member
 
snowflake77's Avatar
 
Join Date: Mar 2007
Posts: 1,203
Current Sled(s): 12 F Turbo, Jag, Panther, & my wife
Previous Sled(s): 04 Team F7/F9 on spray, 04 team f6
Location: Pennsylvania
Favorite Riding Area: Quebec
12-13 Mileage: 3000
11-12 Mileage: 2000
Default Re: Td 4 stage v19 boost numbers

Do you have the stock brv on?

Sent from my SCH-I535 using Snowmobile.com App
snowflake77 is offline   Reply With Quote
Old 02-04-2013, 07:11 PM   #37 (permalink)
Super Advanced Member
 
Join Date: Nov 2004
Posts: 374
Current Sled(s): 2012 f1100 turbo 50th
Previous Sled(s): 2007 f1200 sno pro
Location: Upstate ny
Age: 50
Default

Quote:
Originally Posted by snowflake77 View Post
Do you have the stock brv on?

Sent from my SCH-I535 using Snowmobile.com App
Yes and could not get it to leak during pressure test
black1010 is offline   Reply With Quote
Old 02-04-2013, 07:16 PM   #38 (permalink)
Super Advanced Member
 
snowflake77's Avatar
 
Join Date: Mar 2007
Posts: 1,203
Current Sled(s): 12 F Turbo, Jag, Panther, & my wife
Previous Sled(s): 04 Team F7/F9 on spray, 04 team f6
Location: Pennsylvania
Favorite Riding Area: Quebec
12-13 Mileage: 3000
11-12 Mileage: 2000
Default Re: Td 4 stage v19 boost numbers

Good

Sent from my SCH-I535 using Snowmobile.com App
snowflake77 is offline   Reply With Quote
Old 02-04-2013, 08:30 PM   #39 (permalink)
Super Advanced Member
 
welderllj's Avatar
 
Join Date: Feb 2009
Posts: 882
Default

Well i could not get more then 23 fixed bov now 32 ....now i having problem maxing injectors at 150' ...out.but ill get it lol.....the bov worked for a little while but i believe mine been leaking a long time .....big difference!!!!
welderllj is offline   Reply With Quote
Old 02-20-2013, 09:28 PM   #40 (permalink)
Super Advanced Member
 
trdehmer's Avatar
 
Join Date: Mar 2003
Posts: 3,606
Current Sled(s): 2012 F1100T Retro & 2003 F7
Location: Minnesota
Riding Since: 1984
Default

How did you go about pressure testing the system?

Quote:
Originally Posted by black1010 View Post
Yes and could not get it to leak during pressure test
__________________
Previous Sleds:
2010 Z1 Turbo LXR
2002.5 ZR900
1999 XC 700 SP
1994 XLT SP
1990 Polaris 500
1990 Polaris 340 Sport
1984 Polaris 480 Trail
A Phazer
1969 Massey Ferg Ski Whiz
trdehmer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:34 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0