One slow turbo... - HCS Snowmobile Forums

Turbo 4 Stroke This is the section for all the Turbo 4 Stroke talk This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Sponsored by: Evolution Powersports

Reply
 
LinkBack Thread Tools
Old 02-21-2012, 06:00 PM   #1 (permalink)
Super Advanced Member
 
JimmieK's Avatar
 
Join Date: Nov 2005
Posts: 488
Current Sled(s): Waiting...
Previous Sled(s): 92 Wildcat 95 Zirt8 96 TCat 99TCat 03 F7 07&09 F8 12 F1100T
Location: Canada
Favorite Riding Area: Up north
12-13 Mileage: 1000
11-12 Mileage: 900
10-11 Mileage: 900
Age: 43
Riding Since: 1975
Default One slow turbo...

I had a 2003 Firecat...lots of motor issues...but atleast it was rocket fast @ 117 mph box stock!!! Once bad oil pump was replaced bullet proof and even with a D&D 757 top end and no boondocker I could wax anything in my area.

Fast forward to 2012 F1100T...a few issues but 109 mph is ridiculous. Brought it to my local authorized dealer and all checks out ok. It was hard on gas and real bad staining on white side panel from exhaust found out that there could be possible restiction in return into tank...so tank was changed...no change in top end speed.

I took primary apart when installing T1's and D&D tan spring...all seemed to be moving freely. Installed EZ-jacker and rechecked all turbo connections, cleaned clutches and 107 (yes it was a little mild 0*c but still). RPM's bang on 7900-8000 as per Glen's recommendation for this set up. Stopped to check clutches and were very hot to the touch...dealer said all was in alignment but still getting belt dust.

It pulls hard midrange but no friggen top end. My 2009 F8 was faster!!! (with slight go fast parts of course)

I love this sled but I think I got a dud...sorry for the rant.

Any suggestions?
__________________
JimmieK
JimmieK is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2012, 06:32 PM   #2 (permalink)
Super Advanced Member
 
rgnbull1227's Avatar
 
Join Date: Sep 2006
Posts: 1,726
Current Sled(s): 2012 F1100 Turbo LE HJ 2.0, Meth, ECC, etc.
Previous Sled(s): 2009 HyJacked Z1Turbo
Location: Long Island, NY
Riding Since: 1981
Default

Quote:
Originally Posted by 03 F7 PATRIOT View Post
I had a 2003 Firecat...lots of motor issues...but atleast it was rocket fast @ 117 mph box stock!!! Once bad oil pump was replaced bullet proof and even with a D&D 757 top end and no boondocker I could wax anything in my area.

Fast forward to 2012 F1100T...a few issues but 109 mph is ridiculous. Brought it to my local authorized dealer and all checks out ok. It was hard on gas and real bad staining on white side panel from exhaust found out that there could be possible restiction in return into tank...so tank was changed...no change in top end speed.

I took primary apart when installing T1's and D&D tan spring...all seemed to be moving freely. Installed EZ-jacker and rechecked all turbo connections, cleaned clutches and 107 (yes it was a little mild 0*c but still). RPM's bang on 7900-8000 as per Glen's recommendation for this set up. Stopped to check clutches and were very hot to the touch...dealer said all was in alignment but still getting belt dust.

It pulls hard midrange but no friggen top end. My 2009 F8 was faster!!! (with slight go fast parts of course)

I love this sled but I think I got a dud...sorry for the rant.

Any suggestions?

Somethings a-miss. Hose all tight?
rgnbull1227 is offline   Reply With Quote
Old 02-21-2012, 06:34 PM   #3 (permalink)
Super Advanced Member
 
walleyezr's Avatar
 
Join Date: Jan 2011
Posts: 270
Default

a bone stock 03 f7 113 on asphalt and 107 on hard pac both quarter mile runs how far did you run ?
walleyezr is offline   Reply With Quote
Old 02-21-2012, 06:42 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Oct 2003
Posts: 484
Location: PA
Favorite Riding Area: WNY
12-13 Mileage: 2000
11-12 Mileage: 200 no sno
10-11 Mileage: 2656
Default

is the turbo waste gate opening and closing all the way? Some had problems with some weld in there not letting it work correctly. also the secondarys are cheap chinese junk like a lot of other parts on the sled. Maybe think about putting on an aftermarket.

Last edited by snowmachine; 02-21-2012 at 06:46 PM.
snowmachine is online now   Reply With Quote
Old 02-21-2012, 06:46 PM   #5 (permalink)
Super Advanced Member
 
catchmeifucan's Avatar
 
Join Date: Dec 2004
Posts: 5,671
Current Sled(s): 2012 F1100T SP LTD, 2007 Attak
Previous Sled(s): 1996 TCat 1004, PS1000 Cat
Location: Cape Breton, N.S.
12-13 Mileage: 3000
11-12 Mileage: 2100
10-11 Mileage: 2000
Default

Quote:
Originally Posted by 03 F7 PATRIOT View Post
I had a 2003 Firecat...lots of motor issues...but atleast it was rocket fast @ 117 mph box stock!!! Once bad oil pump was replaced bullet proof and even with a D&D 757 top end and no boondocker I could wax anything in my area.

Fast forward to 2012 F1100T...a few issues but 109 mph is ridiculous. Brought it to my local authorized dealer and all checks out ok. It was hard on gas and real bad staining on white side panel from exhaust found out that there could be possible restiction in return into tank...so tank was changed...no change in top end speed.

I took primary apart when installing T1's and D&D tan spring...all seemed to be moving freely. Installed EZ-jacker and rechecked all turbo connections, cleaned clutches and 107 (yes it was a little mild 0*c but still). RPM's bang on 7900-8000 as per Glen's recommendation for this set up. Stopped to check clutches and were very hot to the touch...dealer said all was in alignment but still getting belt dust.

It pulls hard midrange but no friggen top end. My 2009 F8 was faster!!! (with slight go fast parts of course)

I love this sled but I think I got a dud...sorry for the rant.

Any suggestions?
I got it's twin. 105.8 best speed on gps today, over 2000 ft run. muffler and clutching changes only. And it is is faster than when it was stock, lol. Ran my Attak against it, side by side. I thoughtI was doing ok until the horse and sleigh passed me, lol.
__________________
You will love this!!!
catchmeifucan is offline   Reply With Quote
Old 02-21-2012, 07:36 PM   #6 (permalink)
Super Advanced Member
 
1100saber's Avatar
 
Join Date: Jan 2006
Posts: 2,858
Current Sled(s): 2009 MXZX 1200, 2009 800r Renegade
Previous Sled(s): 2012 F1100 Turbo
Location: Sudbury, ON
12-13 Mileage: 1200
11-12 Mileage: 800
10-11 Mileage: 750
Age: 38
Riding Since: 1980
Default

i think you may need a boost gauge...at least that would give you a starting point
1100saber is offline   Reply With Quote
Old 02-21-2012, 07:47 PM   #7 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 5,018
Current Sled(s): 06 poo 600 2013 lxr f1100 turbo
Location: Waterboro,Maine
Favorite Riding Area: Patten
12-13 Mileage: 2600
11-12 Mileage: 2400
10-11 Mileage: 2000
Age: 58
Riding Since: 1966
Default

Quote:
Originally Posted by 03 F7 PATRIOT View Post
I had a 2003 Firecat...lots of motor issues...but atleast it was rocket fast @ 117 mph box stock!!! Once bad oil pump was replaced bullet proof and even with a D&D 757 top end and no boondocker I could wax anything in my area.

Fast forward to 2012 F1100T...a few issues but 109 mph is ridiculous. Brought it to my local authorized dealer and all checks out ok. It was hard on gas and real bad staining on white side panel from exhaust found out that there could be possible restiction in return into tank...so tank was changed...no change in top end speed.

I took primary apart when installing T1's and D&D tan spring...all seemed to be moving freely. Installed EZ-jacker and rechecked all turbo connections, cleaned clutches and 107 (yes it was a little mild 0*c but still). RPM's bang on 7900-8000 as per Glen's recommendation for this set up. Stopped to check clutches and were very hot to the touch...dealer said all was in alignment but still getting belt dust.

It pulls hard midrange but no friggen top end. My 2009 F8 was faster!!! (with slight go fast parts of course)

I love this sled but I think I got a dud...sorry for the rant.

Any suggestions?
Check your primary cover for binding when hot,see if it is shifting out on fron and back,mark both clutches,and remove the primary,remove spring,reinstall,and see if it moves freely,try and do this while it is hot.
mnmsnowbeast is offline   Reply With Quote
Old 02-21-2012, 07:49 PM   #8 (permalink)
Super Advanced Member
 
87gtNOS's Avatar
 
Join Date: Jan 2003
Posts: 3,706
Location: Toronto
Default

Quote:
Originally Posted by 03 F7 PATRIOT View Post

Any suggestions?
trade with Dan Carlson for the one that he says goes 120mph with no studs!!

quote "Stock Cat Turbo 121 mph stock... & then some "

Last edited by 87gtNOS; 02-21-2012 at 07:55 PM. Reason: add qoute!! LOL!!
87gtNOS is offline   Reply With Quote
Old 02-21-2012, 07:59 PM   #9 (permalink)
jet
Super Advanced Member
 
jet's Avatar
 
Join Date: Mar 2004
Posts: 15,089
Current Sled(s): 2012 F1100 Turbo sno pro
Previous Sled(s): 2008 F1000 sno pro 2003 F7 sno pro
Location: Brainerd, MN
12-13 Mileage: 2700
11-12 Mileage: 1300
10-11 Mileage: 2500
Age: 40
Riding Since: 1983
Default

Mine isn't as fast it should be either, I think i will see huge gains now that I have the skid squared up, after making the adjustments back there I've really got that track spinning free now and lined up square, I also have a clutching/worn belt issue going on as my rpms seem to be all over the place between 7600-8000.. If i can get all this figured out I see big gains comin my way... other problem I got is this sled doesn't steer in fresh snow because the stock ski's SUCK so i'm gonna sacrifice some top speed and put on my powder pro's for the sake of gaining a little in the handling dept.

I hate to throw a muffler on it but I might just do it, an extra 20 horse or what ever it is,is lookin real good right about now on mine.
jet is offline   Reply With Quote
Old 02-21-2012, 08:49 PM   #10 (permalink)
Super Advanced Member
 
68_340_Cuda's Avatar
 
Join Date: Feb 2008
Posts: 1,409
Current Sled(s): 13 MXZ 1200 & 13 MXZ X 800
Previous Sled(s): 12 piece of shit F1100 turbo, 05 Firecat
Location: Ottawa, Ontario
Age: 40
Default

I also have a slow piece of shit, just found out tonight that my clutch binds when on the crank, when I pull it off it's perfect. Something is weird. Mark your primary sheave and go do a few runs and tell me how much of your line remains? Most barely have 1/8" but mine had 5/8", no wonder it's a slug, only getting second gear out of it. I checked everything else I could think of and didn't really find anything. These are clutched bad from the factory with a lot of belt slip on a good day assuming there's no primary binding which would just aggravate the problem
68_340_Cuda is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:10 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0