Need some help - HCS Snowmobile Forums


Turbo 4 Stroke This is the section for all the Turbo 4 Stroke talk This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Sponsored by: Evolution Powersports

Reply
 
LinkBack Thread Tools
Old 03-04-2017, 02:57 PM   #1 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default Need some help

All of a sudden my sled will flash knock light once and lights go out and sled dies. its like it just looses power and will be hard to restart. Looked at all the wiring and can't seem to see anything obvious .
TMB is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2017, 03:12 PM   #2 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

I loosened the throttle cable a bit thinking that maybe it was to tight but that didn't help
TMB is online now   Reply With Quote
Old 03-04-2017, 04:51 PM   #3 (permalink)
720
Super Advanced Member
 
720's Avatar
 
Join Date: Dec 2002
Posts: 2,643
Default

When the lights are involved prolly in the CCU
__________________
If it aint broke keep changing stuff til it is
720 is offline   Reply With Quote
 
Old 03-04-2017, 04:57 PM   #4 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

It started happening last ride you could wiggle the handlebars and make it happen. So I re routed the smaller wiring harness. You can reach in there now and wiggle all the wires and can't get it to do it until you ride it
TMB is online now   Reply With Quote
Old 03-05-2017, 01:37 PM   #5 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

talked to dave from JDP. he thinks its the throttle safety switch. i looked the throttle assembley up but dont see the actual throttle safety switch in the diagram. do i just replace the whole housing?
TMB is online now   Reply With Quote
Old 03-05-2017, 01:49 PM   #6 (permalink)
Super Advanced Member
 
Manitoba Dragon's Avatar
 
Join Date: Jan 2016
Posts: 816
Current Sled(s): 2009 Dragon SP 800
Location: Manitoba
Favorite Riding Area: Snow
15-16 Mileage: 1500
Age: 18
Riding Since: 2014
Default

Quote:
Originally Posted by TMB View Post
talked to dave from JDP. he thinks its the throttle safety switch. i looked the throttle assembley up but dont see the actual throttle safety switch in the diagram. do i just replace the whole housing?

Throttle safety sensor is inside the throttle housing.
Far as I know on every brand you need an entire switch if one fails.
__________________
2009 Dragon 800 SP
Manitoba Dragon is offline   Reply With Quote
Old 03-05-2017, 01:59 PM   #7 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

That's what it looks like to me too. I just ordered up the whole assembly. Thanks dragon
TMB is online now   Reply With Quote
Old 03-11-2017, 10:12 AM   #8 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

Installed new TSS. Fixed my issue. Thank you JDP
TMB is online now   Reply With Quote
Old 03-20-2017, 05:38 PM   #9 (permalink)
TMB
Super Advanced Member
 
TMB's Avatar
 
Join Date: Apr 2009
Posts: 1,483
Current Sled(s): 2014 XF 9 SP
Previous Sled(s): all cats
Location: west side
Favorite Riding Area: kingston plains
15-16 Mileage: 1500
14-15 Mileage: 2000
13-14 Mileage: 3000
Age: 53
Riding Since: 68
Default

Quote:
Originally Posted by TMB View Post
Installed new TSS. Fixed my issue. Thank you JDP
well I geuss I didn't fix my sled. I think I have it narrowed down to somewhere in the throttle housing or the wire hareness leading to it. I can hit the throttle housing and make the sled quit. I can't find anything wrong. I ordered upthe front half with the kill switch assembly and it's on back order till June. I can hit the top of the steering post and make the sled quit too. I'm at a loss as to what's wrong
TMB is online now   Reply With Quote
Old 03-20-2017, 06:24 PM   #10 (permalink)
TommCat Performance
 
Tommcat's Avatar
 
Join Date: Mar 2005
Posts: 28,093
Current Sled(s): 13 Turbo, 07 F6, 72, 73, 74 Cheetahs, 72 Puma
Previous Sled(s): 10 F8, 06 F7, 03 ZR9, 02 ZL6, 98 ZR6, 86 El Tigre 6000
Location: Western Mass
Favorite Riding Area: Maine
15-16 Mileage: 660 feet
Riding Since: 1977
Default

Quote:
Originally Posted by TMB View Post
well I geuss I didn't fix my sled. I think I have it narrowed down to somewhere in the throttle housing or the wire hareness leading to it. I can hit the throttle housing and make the sled quit. I can't find anything wrong. I ordered upthe front half with the kill switch assembly and it's on back order till June. I can hit the top of the steering post and make the sled quit too. I'm at a loss as to what's wrong
Remind me tomorrow, let me stare at a wiring diagram tomorrow and I'll come up with either a fix, or temporary bypass.

Sent from my SM-G900V using Tapatalk
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Authorized dealer for:

Aaen Performance
Bikeman Performance
B3C synthetic fuel treatments
CP-Carrillo
Cyclops LED lighting
Curve Industries
Full Throttle Speed
Hi-Performance Engineering
Millenium Technologies
PDP snowflaps
Sandale Fabrication
Scott Taylor Gears
Thermal Zero
Thunder Products
Tommcat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:44 AM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.