05 900,give gas and stalls - HCS Snowmobile Forums

Fusion This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 03-04-2012, 10:04 PM   #1 (permalink)
Advanced Member
 
Join Date: Jan 2012
Posts: 60
Current Sled(s): 650 polaris w/walhs chassis,900&600 polaris
Location: Augusta Maine
Favorite Riding Area: da stream
11-12 Mileage: 660'
10-11 Mileage: 1500miles
Riding Since: 1990
Default 05 900,give gas and stalls

got an 05' 900 fusion just finished rebuilding the motor in. Every time i give it gas it stalls out, but sled will idle. I brought sled down to dealer the day b4 to have it hooked to computer. there were a couple codes that they had to clear. Fuel pressure checked came out perfect. Compression 130+
What is going on? any ideas?
walhsracing24/7 is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2012, 10:05 PM   #2 (permalink)
Advanced Member
 
Join Date: Jan 2012
Posts: 60
Current Sled(s): 650 polaris w/walhs chassis,900&600 polaris
Location: Augusta Maine
Favorite Riding Area: da stream
11-12 Mileage: 660'
10-11 Mileage: 1500miles
Riding Since: 1990
Default

also checked for air leaks, couldnt find any...checked with carb cleaner
walhsracing24/7 is online now   Reply With Quote
Old 03-05-2012, 07:14 PM   #3 (permalink)
Super Advanced Member
 
polarisguy's Avatar
 
Join Date: Sep 2006
Posts: 244
Current Sled(s): 900 Fusion,xc500, xcsp 600
Previous Sled(s): formula z, xc700
Location: Sabattus,ME
Favorite Riding Area: Jackman,Me. Eustis
13-14 Mileage: 1356
12-13 Mileage: 450
11-12 Mileage: 765
10-11 Mileage: 1126
Age: 40
Riding Since: 15
Default

Fuel filter new? Throttle safety switch? Throwing out some ideas for ya.
__________________
POLARIS DA WAY OUT
polarisguy is offline   Reply With Quote
Old 03-07-2012, 08:47 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Jan 2006
Posts: 171
Current Sled(s): 06 900 Switchback, 01 XCR800, 02 XC SP 500
Previous Sled(s): 97 Indy 500, 98 XC 700
Location: Port Sanilac, MI
Favorite Riding Area: Seney, Grand Marais, Newberry
12-13 Mileage: Not enough
Riding Since: 1996
Default

The 05 and 06 900 and FST are having problems with fuel pick-up in the tank breaking down. Look in your tank and see if the pick-up lines are fallen apart in the tank. I had to replace mine on my 06 switchback. I have also seen a FST and 05 Fusion which did the same thing.
xcrswitchbackjjb is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:27 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0