High beam indicator - HCS Snowmobile Forums

Fusion This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 11-28-2011, 06:08 PM   #1 (permalink)
Advanced Member
 
Join Date: Nov 2003
Posts: 69
Current Sled(s): 06 600 fusion
Previous Sled(s): many polaris
Location: rindge nh
10-11 Mileage: 2000
Age: 52
Riding Since: 1981
Default High beam indicator

Hi, I have an 06 600. My high beam indicator is glowing
slightly on low beam. I'm assuming I have a short somewhere.
I cleaned and greased the electrical connections way back so they
should be ok. I'm thinking its in the switch. This happen to anyone
before? How did you fix it? Thanks Jon
99xcsp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2011, 07:31 AM   #2 (permalink)
Super Advanced Member
 
Lightning Rod's Avatar
 
Join Date: Mar 2005
Posts: 821
Current Sled(s): 06 Dragon 600HO, 08 RR
Previous Sled(s): 03 Edge X 700
Location: Taxachusetts
Favorite Riding Area: NH, ME
13-14 Mileage: 1150
12-13 Mileage: 1900
11-12 Mileage: 1400
10-11 Mileage: Not enough
Default

Me Too

Mine lightly flashes ever since I upgraded and relocated the regulator
__________________
BATTEN ELECTRIC

Your complete source for a wired world...
Lightning Rod is offline   Reply With Quote
Old 12-07-2011, 08:53 PM   #3 (permalink)
Advanced Member
 
Join Date: Nov 2003
Posts: 69
Current Sled(s): 06 600 fusion
Previous Sled(s): many polaris
Location: rindge nh
10-11 Mileage: 2000
Age: 52
Riding Since: 1981
Default

bump
99xcsp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:12 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0