Thumb warmer not working - HCS Snowmobile Forums

Nytro This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 03-09-2013, 09:44 PM   #1 (permalink)
Member
 
MNytroRTX's Avatar
 
Join Date: Dec 2012
Posts: 22
12-13 Mileage: 1600
Question Thumb warmer not working

So I decided to "find" a beaver dam up in the Upper Peninsula of MI. The problem is when I nosed into the other side I jammed my hand on the throttle and it bent up a little bit. That night on the 5 degree ride home I found out what it's like to not have a working thumb warmer. Has this happened to anyone else or does anyone know how to fix it or what to look for? I don't want to waste my money at the dealer!!!
MNytroRTX is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-13-2013, 05:17 PM   #2 (permalink)
Member
 
MNytroRTX's Avatar
 
Join Date: Dec 2012
Posts: 22
12-13 Mileage: 1600
Default

No one has had this happen to them before????????????????
MNytroRTX is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0