Check engine light on a '08 mxz 800 - HCS Snowmobile Forums

XP/XR New Style MXZ This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-25-2011, 09:10 AM   #1 (permalink)
Super Advanced Member
 
flying dutchman's Avatar
 
Join Date: Oct 2005
Posts: 165
Current Sled(s): 2014 XF limited 8000- '97 trail-'94 Indy Lite
Previous Sled(s): 2002 Polaris XCSP EDGE 600
Location: South Central MB
Favorite Riding Area: Whiteshell MB - Spruce Woods
13-14 Mileage: 1900
12-13 Mileage: 2100
11-12 Mileage: 5
10-11 Mileage: 1500
Age: 30
Riding Since: 1996
Default Check engine light on a '08 mxz 800

My check engine light came on after we had just trailered it 100 miles.

Any suggestions on what to check? we did put regular grade fuel in it, b/c we had no other options.
flying dutchman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0