08 F6 problem - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 03-18-2012, 12:21 AM   #1 (permalink)
Super Advanced Member
 
the_way_out's Avatar
 
Join Date: Nov 2006
Posts: 1,102
Current Sled(s): 04 Sabercat 500
Previous Sled(s): 00 500 XCSP
Location: Portland
Favorite Riding Area: Seney/Grand Marais
10-11 Mileage: 300
Age: 22
Riding Since: 1994
Default 08 F6 problem

I have a 08 F6 LXR, just bought. When I turn the motor off the speedo pod lights and the taillight stay on draining the battery.
Any help would be great.

Thanks
the_way_out is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-18-2012, 07:20 AM   #2 (permalink)
Super Advanced Member
 
Join Date: Dec 2002
Posts: 10,170
Riding Since: 1861
Default

Try unplugging the CCU (above the RH footrest on the spar). For some it's a one time thing / for others it means replacing the CCU, odd time it's a wire rubbed through.
zr sled head is offline   Reply With Quote
Old 03-18-2012, 10:40 PM   #3 (permalink)
Super Advanced Member
 
Join Date: Mar 2003
Posts: 12,208
Current Sled(s): "Agri-vater"
Default

Thats a new one for me. Please let us know what you find. If you replace that ccu, if it's like the larger sleds the wire runs between the frame and the gas tank and the white plug on the end will not slide through this tight spot, don't move the tank like I did the first time, just pop the wires out of the plug so that they can pass through the gap and the reinstall.
stronger800 is offline   Reply With Quote
Old 04-17-2012, 03:58 PM   #4 (permalink)
Super Advanced Member
 
the_way_out's Avatar
 
Join Date: Nov 2006
Posts: 1,102
Current Sled(s): 04 Sabercat 500
Previous Sled(s): 00 500 XCSP
Location: Portland
Favorite Riding Area: Seney/Grand Marais
10-11 Mileage: 300
Age: 22
Riding Since: 1994
Default

it was the CCU.

and yeah, i spend a ton of time trying to get it between the gas tank and frame. with a lot of patience and a little prying, it will fit through it.
the_way_out is offline   Reply With Quote
Old 04-17-2012, 09:55 PM   #5 (permalink)
Super Advanced Member
 
Join Date: Dec 2002
Posts: 10,170
Riding Since: 1861
Default

Good to hear yer fixed up.
zr sled head is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0