> Post any problems on the 2010 F-Series here, Post Defects your finding after delivery - Page 3 - HCS Snowmobile Forums

F series (07- ) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-22-2010, 07:09 AM   #21 (permalink)
Advanced Member
 
Join Date: Dec 2007
Posts: 64
Current Sled(s): F5LXR
Previous Sled(s): 07 Apex ,04 T660 turbo
Location: Colebrook N.H.
Favorite Riding Area: northern coos county N.H.
10-11 Mileage: 450
Age: 68
Riding Since: 1969
Default

Thanks for reply on gas use. I have about 400 miles now, I'll do the math. Any sugestion on clutch constantly shifting up & down at trail sppeeds.
__________________
fortynine
fortynine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2010, 01:38 PM   #22 (permalink)
Super Moderator
 
tommcat's Avatar
 
Join Date: Mar 2005
Posts: 22,357
Current Sled(s): 13 F1100T LXR, 07 F6, 72 Cheetah 440
Previous Sled(s): 10 F8, 06 F7, 03 ZR9, 02 ZL6, 98 ZR6, 86 El Tigre 6000
Location: MASSHOLE
Favorite Riding Area: Far away from CT people
Riding Since: 1977
Default

QUOTE (fortynine @ Feb 22 2010, 06:09 AM)
Quote:
Thanks for reply on gas use. I have about 400 miles now, I'll do the math. Any sugestion on clutch constantly shifting up & down at trail sppeeds.[/b]
all due to the bad secondary clutch design on the DD sleds. supposedly the torsional conversions fix that, i havent tried one yet but will be soon. i'm trying to find a good deal on an entire secondary clutch so i can set one up with the torsional and make a direct swap right on the trail to compare.
__________________
tommcat is offline   Reply With Quote
Old 02-26-2010, 07:00 PM   #23 (permalink)
Super Advanced Member
 
favoritos's Avatar
 
Join Date: Dec 2006
Posts: 2,348
Current Sled(s): 2013 F8 SP
Previous Sled(s): F8 EXT, Lots of Crossfires
Location: North Twin Cities
Favorite Riding Area: U.P.
11-12 Mileage: not enough
10-11 Mileage: 2,900
Default

Clutch spring in primary goes kablamo pretty quick. You can still ride the thing home, but the original spring in the 800 has issues.
__________________
I'm still learning.
favoritos is offline   Reply With Quote
Old 03-02-2010, 03:50 AM   #24 (permalink)
Advanced Member
 
Join Date: Dec 2007
Posts: 64
Current Sled(s): F5LXR
Previous Sled(s): 07 Apex ,04 T660 turbo
Location: Colebrook N.H.
Favorite Riding Area: northern coos county N.H.
10-11 Mileage: 450
Age: 68
Riding Since: 1969
Default

QUOTE (favoritos @ Feb 26 2010, 06:00 PM)
Quote:
Clutch spring in primary goes kablamo pretty quick. You can still ride the thing home, but the original spring in the 800 has issues.[/b]
My F5 LXR rear suspension shock fades fast to nothing. 550 miles on it , After 1/2 hour riding rear end starts bouncing. Anyone else having this trouble or is it just bad shock?
__________________
fortynine
fortynine is offline   Reply With Quote
Old 12-21-2010, 12:47 PM   #25 (permalink)
Newbie
 
Join Date: Dec 2010
Posts: 3
Current Sled(s): 2010 F8 Snow Pro Ltd.
Previous Sled(s): 2007 F8, 2004 F6 fighter pilot ed.,
Location: manitoba
Favorite Riding Area: Turtle mountains
10-11 Mileage: 500-1000
Age: 42
Riding Since: 1976
Default F8 2010

Just wondering if anyone has this problem. While riding my sled will sometimes go into limp mode. The ECU flashes on the screen. I have to turn it off and that solves the problem for awhile. My dealer said its common with a new sled and thats its just the computer learning the sled. I have just under 500 miles on it . Anyone else experienced this?
sherman.g is offline   Reply With Quote
Old 12-21-2010, 06:56 PM   #26 (permalink)
Super Advanced Member
 
john deer's Avatar
 
Join Date: Mar 2008
Posts: 147
Current Sled(s): 09 Z1 Turbo
Previous Sled(s): mach z, Indy,VMax,Eltigre,Liquifire
Location: northern IN.
Favorite Riding Area: U.P. of MI.
Age: 45
Riding Since: 1973
Default

Picked up a 2010 F8 leftover for a friend who is coming off a Yamaha, He has only owned Yamaha's. After riding my z1 turbo he decided it was time to jump ship, unfortunately when he took it out, after 5 miles the center shock fell out. He is not impressed with cat quality so far
john deer is offline   Reply With Quote
Old 03-21-2011, 07:09 PM   #27 (permalink)
Super Advanced Member
 
browndogg's Avatar
 
Join Date: Feb 2005
Posts: 795
Current Sled(s): 015 ZR 9000 LXR
Previous Sled(s): 2010 F8 Sno Pro
Location: Manitoba
Favorite Riding Area: SANDILANDS
13-14 Mileage: 1400
Default

3500 miles.Timing sensor.Not sure which one as I see on Browns Leisure world micro fiche there are 2.Sled starting cutting out and stalling and sputtering.Thought it might have been stator but dealer found the wires leading to the sensor had worn bare(something to check) and was shorting out the sensor.All fixed.
browndogg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:35 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0