2007 phazer wont start - HCS Snowmobile Forums

Phazer This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 10-18-2009, 09:47 PM   #1 (permalink)
Advanced Member
 
Join Date: Oct 2009
Posts: 63
Current Sled(s): 07 Phazer (clutch kit,96studs,
Location: Lakefield
Default

I just bought and 07 phazer. started it up in my garage alot to hear it cause i got an fmf pipe on it. i ran it right dry one day by accident. i ran all the new gas through again and finnally got it started. then 2 days later it wont start anymore. i do need a new battery but i just hooked it up to a charger and it still wont start. Help me out.... thanks.
__________________
Always buy the biggest engine, letting off the throttle is a good thing

Snowmobiling is a sport, its is in the X Games!!!!!!
phazerfmf is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2009, 10:37 PM   #2 (permalink)
Super Advanced Member
 
prav's Avatar
 
Join Date: Dec 2007
Posts: 463
Location: Northern IL
Default

Quote:
I just bought and 07 phazer. started it up in my garage alot to hear it cause i got an fmf pipe on it. i ran it right dry one day by accident. i ran all the new gas through again and finnally got it started. then 2 days later it wont start anymore. i do need a new battery but i just hooked it up to a charger and it still wont start. Help me out.... thanks.[/b]

Does it crank?
prav is offline   Reply With Quote
Old 10-19-2009, 10:36 PM   #3 (permalink)
Advanced Member
 
PattyJack's Avatar
 
Join Date: Dec 2007
Posts: 70
Default

My guess is you fouled the plugs from the constant starting and stopping.
PattyJack is offline   Reply With Quote
Old 10-20-2009, 03:32 PM   #4 (permalink)
Super Advanced Member
 
Join Date: Jan 2009
Posts: 269
Current Sled(s): 08 600rs
Previous Sled(s): 07 phazer
Location: marcellus NY
Age: 16
Riding Since: 1998
Default

ya, remember, let it idle down to 1700rpm before shutting it off. and plugs are a BITCH to get out
yo dude 12 is offline   Reply With Quote
Old 10-20-2009, 03:47 PM   #5 (permalink)
Super Advanced Member
 
Join Date: Dec 2008
Posts: 330
Location: Michigan
Default

Quote:
ya, remember, let it idle down to 1700rpm before shutting it off. and plugs are a BITCH to get out[/b]

you have to take the whole gas tank off to get them out.
07fx4stroke is offline   Reply With Quote
Old 10-20-2009, 05:45 PM   #6 (permalink)
Advanced Member
 
Join Date: Oct 2009
Posts: 63
Current Sled(s): 07 Phazer (clutch kit,96studs,
Location: Lakefield
Default

i have it all pulled apart. it is a bitch. took me like 2 hours to get to the plugs. they were all black and gumed up. also they havent ever been changed by the previos oeners. it only has 3500km so i guess its time. i am getting the plugs wednesday. hope that fixes it.
__________________
Always buy the biggest engine, letting off the throttle is a good thing

Snowmobiling is a sport, its is in the X Games!!!!!!
phazerfmf is offline   Reply With Quote
Old 10-20-2009, 06:30 PM   #7 (permalink)
Super Advanced Member
 
natty793's Avatar
 
Join Date: Dec 2004
Posts: 1,029
Default

I did the same thing when I first got mine, always starting it up for friends to listen to it and I fouled the plugs.
natty793 is offline   Reply With Quote
Old 10-20-2009, 09:57 PM   #8 (permalink)
Super Advanced Member
 
yzf1999's Avatar
 
Join Date: Nov 2004
Posts: 472
Location: (F.I.B.)
Default

Yeah, let it warm up if you start it and you shouldn't foul the plugs. I changed mine when I had the tank off installing the Hauck fuel management system to the fuel injectors...It is a complete BITCH, so if your there already I'd change the stock plugs if they have never been changed (especially if you bought your sled used),
yzf1999 is offline   Reply With Quote
Old 11-17-2009, 07:16 PM   #9 (permalink)
Advanced Member
 
etaworks's Avatar
 
Join Date: Nov 2008
Posts: 91
Location: Wynantskill,NY
Default

I got my o8 rtx new so I got the heads up on not touching the throttle untill machine idels down , or you will foul plugs, still have stock plugs, 1400 miles
etaworks is offline   Reply With Quote
Old 11-20-2009, 03:33 PM   #10 (permalink)
Super Advanced Member
 
Join Date: Jan 2009
Posts: 269
Current Sled(s): 08 600rs
Previous Sled(s): 07 phazer
Location: marcellus NY
Age: 16
Riding Since: 1998
Default

Quote:
you have to take the whole gas tank off to get them out.[/b]

thats what i mean as BITCH haha and i love how everyone under me said BITCH lmao
yo dude 12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:55 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0