94' polaris 300 4x4 - HCS Snowmobile Forums

Reply
 
LinkBack Thread Tools
Old 01-27-2009, 11:27 AM   #1 (permalink)
Advanced Member
 
Join Date: Jan 2009
Posts: 56
Current Sled(s): 04' 800 Switchback, 11' 800 SB Assualt
Previous Sled(s): numerous polaris......
Location: Bay City, MI
Favorite Riding Area: Houghton County
Age: 29
Riding Since: 1989
Default

I just purchased this machine and at the time of purchase realized that it is a 2 stroke machine. I was curious what type of oil is typically run in this machine.
(polaris blue????) And i am a first time automatic atv owner, is the belt on this quad similar to my sled, do people typically carry a spare such that we do snowmobiling. Any help about the machine would be appreciated.
dubser31 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-30-2009, 11:27 AM   #2 (permalink)
Super Advanced Member
 
Join Date: May 2006
Posts: 625
Default

I always use Polaris Blue. Same drive as a sled. Those machines don't make enough HP to destroy a belt so I don't carry an extra. Worst case is that you burn it some how and it will "thump" but you will still get home. Use low range when in a steep spot or pulling some thing and you won't burn the belt. Don't be decieved they are faster and tons lighter than a 500. Front struts go bad on them and don't waste your money on after market, they don't last. Buy OEM.
BB454 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:33 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0