2005 Rage tachometer not working - HCS Snowmobile Forums


Venture This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 12-26-2016, 12:52 PM   #1 (permalink)
Member
 
Join Date: Nov 2009
Posts: 24
Location: Ct
Default 2005 Rage tachometer not working

I recently purchased a 2005 Rage from a friend. Prior to me purchasing the sled my friend had rolled the sled last season when he was ran off the trail and into the ditch by an oncoming sled thus taking out the windshield and the right mirror. We replaced the windshield but the tach stopped working. Any advice on what could be wrong besides a faulty display screen would be appreciated. Everything else on the screen is working properly. Also looking for a right mirror.
neck is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:53 PM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.