2010 Polaris 800's - HCS Snowmobile Forums

Switchback/SKS/RMK This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 02-22-2010, 07:03 PM   #1 (permalink)
Advanced Member
 
Timberwolffe's Avatar
 
Join Date: Feb 2009
Posts: 43
Default

Has anyone melted down a 2010 800 or has Polaris "patched" the problem? Goin on a 400+ mile trip in two weeks and want to know how worried to be. Any input at all is appreciated....THANKS in advance.
Timberwolffe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2010, 09:42 PM   #2 (permalink)
Super Advanced Member
 
snowman4's Avatar
 
Join Date: Mar 2006
Posts: 415
Current Sled(s): 2015 SB Assault LE/2003 ProX 700 SKS 136
Previous Sled(s): 05 F7/06 Attak/08 600RR/10 Assault/13 Freeride/14 Gade 800X
Location: Anywhere that has snow
Favorite Riding Area: anywhere
13-14 Mileage: 1150
12-13 Mileage: 1200
11-12 Mileage: 1500
10-11 Mileage: 350
Age: 36
Riding Since: 1983
Default

I have 1400 miles on my 2010 Assault with no problems at all. The sled is bone stock with the Jan. 14 2010 Fuel update and that's it, a friend of mine has a 2010 800 Dragon Switchback with over 4000 miles on it and he is also all stock with the Jan. 14 Fuel update.

THe mid range stumble is still their but not all the time. The sled are running awesome, have a fun trip and just make sure to run good fuel, 92 octane or better. I carry a octane booster with me just in case I get worried.
snowman4 is offline   Reply With Quote
Old 02-22-2010, 10:03 PM   #3 (permalink)
Super Advanced Member
 
Bowana's Avatar
 
Join Date: Feb 2007
Posts: 264
Current Sled(s): 2012 Renegade XR 1200
Previous Sled(s): 2010 Polaris 800 Switchback
Location: Regina, SK
Favorite Riding Area: Saskatchewan
13-14 Mileage: 2014
12-13 Mileage: 3591
11-12 Mileage: 2389
10-11 Mileage: 2850
Riding Since: 1967
Default

QUOTE (snowman4 @ Feb 22 2010, 08:42 PM)
Quote:
I have 1400 miles on my 2010 Assault with no problems at all. The sled is bone stock with the Jan. 14 2010 Fuel update and that's it, a friend of mine has a 2010 800 Dragon Switchback with over 4000 miles on it and he is also all stock with the Jan. 14 Fuel update.

THe mid range stumble is still their but not all the time. The sled are running awesome, have a fun trip and just make sure to run good fuel, 92 octane or better. I carry a octane booster with me just in case I get worried.[/b]
I put 800 miles on a 2010 Switch in the past 10 days and it ran great. Looking for clutching solution as it does not close the front clutch completly but runs 102 on hard park and 1/2 mile run. I ran 91 octane and also 87 regular with the wire unplugged. Performance drops off but very rideable.

Best of the box sled I have owned and there have been several over the years.
__________________
2012 Rev XR Renegade Adrenaline. Deluxe Travel Bag, Gears Handlebar Bag, 12 volt plug in, heat guage hook up, heated visor plug, Power Madd 6 inch riser, 17 1/2 inch sport windshield, PB 80, MBRP Header & a little Cudney package. Exit shocks by Monster Performance. Skins Hand Guards.
Bowana is offline   Reply With Quote
Old 02-23-2010, 09:27 AM   #4 (permalink)
Super Advanced Member
 
Join Date: Dec 2007
Posts: 250
Current Sled(s): 2012 PR-R 800 SB, 08 600rr
Previous Sled(s): 79txl 95 xlt sp
Location: Michigan
Favorite Riding Area: U.P MICHIGAN
12-13 Mileage: 1800
11-12 Mileage: 1100
10-11 Mileage: 2100
Age: 33
Riding Since: 1988
Default

I have a 2010 dragon switch back. 1100 miles on her. all stock w/ jan 14th update. slight stumble but rocks hard. no other problems other that the front arm shock spring broke (under the track). Pulled 113mph @8400rpms. Poo are the shit.


flex600rr is offline   Reply With Quote
Old 02-23-2010, 08:31 PM   #5 (permalink)
Advanced Member
 
Join Date: Jan 2009
Posts: 51
Default

Don't worry just go have fun. P.S. If you read to much on this forum everyone would have you believing you can't even leave your yard without blowing up a D8. Cheers, D.J.
ratnutz is offline   Reply With Quote
Old 02-26-2010, 12:48 PM   #6 (permalink)
Newbie
 
Join Date: Jan 2010
Posts: 8
Default

i have a 2010 Polaris Assault and alls i got on it is a MBRP loud can and my DET sensor would go off and my Check Eng. light would flash and i wouldnt have anypower. I brought it in in january had the reflash done and last weekend it pulled the same shit it was powerless between 6300 and 7400rpm and goin to Cookcity March 11 so idk what i should do about it???
Tdietzler is offline   Reply With Quote
Old 02-26-2010, 12:50 PM   #7 (permalink)
Newbie
 
Join Date: Jan 2010
Posts: 8
Default

QUOTE (ratnutz @ Feb 23 2010, 07:31 PM)
Quote:
Don't worry just go have fun. P.S. If you read to much on this forum everyone would have you believing you can't even leave your yard without blowing up a D8. Cheers, D.J.[/b]

o yeah theres 650 miles on it. and i run 91 with the wires plugged in
Tdietzler is offline   Reply With Quote
Old 02-26-2010, 02:31 PM   #8 (permalink)
Advanced Member
 
motoman614's Avatar
 
Join Date: Oct 2007
Posts: 56
Current Sled(s): 2010 RMK 800
Location: Larimore, ND
Favorite Riding Area: Cooke City, MT
Age: 34
Riding Since: 1990
Default

[quote]i have a 2010 Polaris Assault and alls i got on it is a MBRP loud can and my DET sensor would go off and my Check Eng. light would flash and i wouldnt have anypower. I brought it in in january had the reflash done and last weekend it pulled the same shit it was powerless between 6300 and 7400rpm and goin to Cookcity March 11 so idk what i should do about it???[/quote


Get a PCV
motoman614 is offline   Reply With Quote
Old 02-27-2010, 09:53 PM   #9 (permalink)
Super Advanced Member
 
snowman4's Avatar
 
Join Date: Mar 2006
Posts: 415
Current Sled(s): 2015 SB Assault LE/2003 ProX 700 SKS 136
Previous Sled(s): 05 F7/06 Attak/08 600RR/10 Assault/13 Freeride/14 Gade 800X
Location: Anywhere that has snow
Favorite Riding Area: anywhere
13-14 Mileage: 1150
12-13 Mileage: 1200
11-12 Mileage: 1500
10-11 Mileage: 350
Age: 36
Riding Since: 1983
Default

QUOTE (Tdietzler @ Feb 26 2010, 12:48 PM)
Quote:
i have a 2010 Polaris Assault and alls i got on it is a MBRP loud can and my DET sensor would go off and my Check Eng. light would flash and i wouldnt have anypower. I brought it in in january had the reflash done and last weekend it pulled the same shit it was powerless between 6300 and 7400rpm and goin to Cookcity March 11 so idk what i should do about it???[/b]
I had the same MBRP can on my 2010 Assault and it did the exact same thing that your sled did....took the can off and put it back to stock and it runs great.

I have the Jan. 14 2010 re-flash and it runs ten times better, still the stumble hear n there but I can deal with it. This Assault is just plain AWESOME WOOP WOOP hahaha lol.

Think about buying the SLP Silencer out of the Polaris Accessory Book to save some weight, plus its supposed to be quiet enough to creap by the Police. Also thing about buying a PCV next year from Jim at Dyno Tech and see how it runs.
snowman4 is offline   Reply With Quote
Old 02-28-2010, 10:52 AM   #10 (permalink)
Super Advanced Member
 
snowman4's Avatar
 
Join Date: Mar 2006
Posts: 415
Current Sled(s): 2015 SB Assault LE/2003 ProX 700 SKS 136
Previous Sled(s): 05 F7/06 Attak/08 600RR/10 Assault/13 Freeride/14 Gade 800X
Location: Anywhere that has snow
Favorite Riding Area: anywhere
13-14 Mileage: 1150
12-13 Mileage: 1200
11-12 Mileage: 1500
10-11 Mileage: 350
Age: 36
Riding Since: 1983
Default

QUOTE (Tdietzler @ Feb 26 2010, 12:50 PM)
Quote:
o yeah theres 650 miles on it. and i run 91 with the wires plugged in[/b]
Wire should only be plugged in when running gas with NO ethanol, if you even think the gas might have ethanol in it leave the wire unplugged.

snowman4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:30 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0