Citgo sea and snow - Page 5 - HCS Snowmobile Forums


Pro-X (2001-2004) This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited.

Reply
 
LinkBack Thread Tools
Old 01-03-2011, 06:41 PM   #41 (permalink)
Super Advanced Member
 
alsled's Avatar
 
Join Date: Sep 2005
Posts: 12,152
Current Sled(s): 2015 XF8000LXR
Previous Sled(s): 92,93,94,95,96,97,02,03,04,06, polaris's
Location: WNY
Favorite Riding Area: On Snow
14-15 Mileage: 1100
Age: 49
Riding Since: 1991
Default

Quote:
Originally Posted by krazyzx9 View Post
Did some checking at some local fleet farms and one in Green Bay yesterday before the game....only Mystik.....bummer

What is on the mystic label, whats it called?
alsled is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-03-2011, 06:57 PM   #42 (permalink)
Super Advanced Member
 
blokhead's Avatar
 
Join Date: Jan 2004
Posts: 198
Current Sled(s): 1998 XC700 (220) Edge 136" skid, 1.25 Ripsaw,
Location: Cleveland
Default

Quote:
Originally Posted by alsled View Post
What is on the mystic label, whats it called?

Mystik Sea & Snow


View more items in SNOWMOBILE


Description
For high perfomance Snowmobiles and Personal Watercraft with liquid cooled or air cooled 2-cycle engines. Synthetic blend, low ash 2-stroke cycle lubricant certified for high international standards: ISO EGD, JASO FD and API TC.
__________________
1998 XC700 (220) Edge 136" skid, 1.25 Ripsaw, RKT Head, Hot Seat Twins, V-Force II, SLP Boost Bottle, & The Holy Grail HSP38X

"79 Kawasaki Drag Bike w/1998 XC700 (220) Twin 162 hp @ 8300 rpm 9.68 @ 132 mph
blokhead is offline   Reply With Quote
Old 01-03-2011, 08:21 PM   #43 (permalink)
Super Advanced Member
 
alsled's Avatar
 
Join Date: Sep 2005
Posts: 12,152
Current Sled(s): 2015 XF8000LXR
Previous Sled(s): 92,93,94,95,96,97,02,03,04,06, polaris's
Location: WNY
Favorite Riding Area: On Snow
14-15 Mileage: 1100
Age: 49
Riding Since: 1991
Default

http://www.docs.citgo.com/msds_pi/C10008.pdf
alsled is offline   Reply With Quote
 
Old 01-05-2011, 10:31 PM   #44 (permalink)
Advanced Member
 
Join Date: Dec 2010
Posts: 41
Current Sled(s): 06 fusion 600ho
Default

Yah the Meijer has Mystic, I went to get SnS one day and left because all they had was the Mystic. Later that night is when I found it is the same stuff.
mjjstang is offline   Reply With Quote
Old 01-06-2011, 12:22 PM   #45 (permalink)
Super Advanced Member
 
Join Date: Sep 2005
Posts: 26,563
Current Sled(s): 05 600 xcsp 50th
Previous Sled(s): All of the big 4
Location: Ct.
Favorite Riding Area: Ma.
15-16 Mileage: Zero
14-15 Mileage: not much
Age: 6
Riding Since: 70 s
Default

Quote:
Originally Posted by alsled View Post
Now I'm scared.
ASTM D4858 -08 Standard Test Method for Determination of the Tendency of Lubricants to Promote Preignition in Two-Stroke-Cycle Gasoline Engines

I have been having big problems with the det light coming on, the only thing i changed was oil, from redline to CSnS.

WTF. more things to figure out
Buddy of mine started using spectro syn-snow in the 04 800 pro x he now owns...runs really well... no deto or temp lights came on last saturday as it was 54 degrees out by mid day. No idea what the previous sleds owner ran in before...looked like regular motor oil in color and smelt like bubble gum what was left in the tank.
too slow is offline   Reply With Quote
Old 01-06-2011, 09:57 PM   #46 (permalink)
Super Advanced Member
 
Join Date: Dec 2009
Posts: 281
Current Sled(s): 2004 pro-xr 800 & 2002 XC 800 SP
Age: 31
Riding Since: 2006
Default

Mystik JT-4 2-Cycle Snowmobile Engine

Oil
Weaver338 is offline   Reply With Quote
Old 02-17-2017, 12:42 PM   #47 (permalink)
Super Advanced Member
 
93polarisxlt's Avatar
 
Join Date: Mar 2008
Posts: 471
Current Sled(s): 99 xc700, 04 XC 700
Previous Sled(s): 93 XLT
Location: Chippewa falls
Age: 48
Default

You guys still USING THE Mystik sea and snow oil in your VES sleds?

https://www.farmandfleet.com/product...obile-oil.html
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by 93polarisxlt; 02-17-2017 at 12:51 PM.
93polarisxlt is offline   Reply With Quote
Old 02-18-2017, 10:34 AM   #48 (permalink)
Super Advanced Member
 
gaige2's Avatar
 
Join Date: Jan 2007
Posts: 724
Current Sled(s): CFR 1000 & PRO X2 800
Previous Sled(s): MANY
Location: QUEBEC
Favorite Riding Area: EVERYWHERE
Default

I have used it and it was good, I use a variety of oils and my motors have been perfectly reliable. I buy on price and certifications of the oil then buy a case of it.
You'd be fine with this oil,, good luck,, Oh ya this quite an old thread,, good find.
Cheers
gaige2 is offline   Reply With Quote
Old 02-20-2017, 12:06 AM   #49 (permalink)
Super Advanced Member
 
93polarisxlt's Avatar
 
Join Date: Mar 2008
Posts: 471
Current Sled(s): 99 xc700, 04 XC 700
Previous Sled(s): 93 XLT
Location: Chippewa falls
Age: 48
Default

I see I bought the synthetic blend and not the full full synthetic , will it still be ok for my sled with VES?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
93polarisxlt is offline   Reply With Quote
Old 02-20-2017, 12:37 AM   #50 (permalink)
Super Advanced Member
 
-dw-'s Avatar
 
Join Date: Dec 2005
Posts: 2,478
Current Sled(s): deTweaked 13 Indy, 01 600xcsp, 00 600xcsp
Previous Sled(s): 3 arcticcraps
Location: Central Mn
Favorite Riding Area: from my house
Age: 37
Riding Since: 85
Default

Quote:
Originally Posted by 93polarisxlt View Post
I see I bought the synthetic blend and not the full full synthetic , will it still be ok for my sled with VES?
My 00xcsp6 has nothing run it but regular Injex from when I bought it 17yrs ago. Valves gummed up quicky, woop de doo, I cleaned them. My 13 Indy only got Sea and Snow semi syn since new, valves were clean at 2000 miles. Also I have mixed about 1oz of non syn per gal.
-dw- is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:45 PM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.