1988 ski doo safari voyageur 503 clutch question? - HCS Snowmobile Forums

Reply
 
LinkBack Thread Tools
Old 01-15-2011, 09:01 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2011
Posts: 2
Default 1988 ski doo safari voyageur 503 clutch question?

Hey guys and gals im new to this forum and snowmobiling as of this year. i bought a 88 safari voyaguer 503 and it runs good but i have a question. when i start up the sled and when im turning the sled off there is a clanky sound and i wasnt sure what it was but my friend i ride with thinks it may be my clutch being loose? the sled runs fine when i get going and i havent had problems going fast on it either. after i ride for awhile and the sled is all warmed up and its idleing it doesnt make this clanking sound. i dont know much about sleds but i was hopeing somone could tell me wnat my problem could be. i took the gaurd off around the fan belt clutch area and noticed the clutch area jolts and clanks a bit when i shut it off. but she starts up every time and im just wondering if becuase this is an old sled its just somthing that happens?? any help is appreaciated.
88safari503 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-25-2011, 08:09 AM   #2 (permalink)
Newbie
 
Join Date: Jan 2011
Posts: 8
Default

I have the same problem with my 86 Formula Plus...I'm gonna take the clutch off this weekend, so I'll let you know what i find.
cottageandy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:00 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0