Yamaha exciter clutch sticking? - HCS Snowmobile Forums

Yamaha General Discussion This is a brand-specific forum. Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. This is a 100% NO BASH ZONE. Please be aware that if you violate this policy you are in danger of losing your posting privileges on this website.The calling out or posting of another members personal information IE phone number or address is prohibited. Sharing of private messages from site staff is against site rules and will be subject to banning from site temporarily or permanently.

Reply
 
LinkBack Thread Tools
Old 12-18-2011, 09:08 PM   #1 (permalink)
Super Advanced Member
 
Join Date: Dec 2011
Posts: 111
Current Sled(s): 2008 polaris dragon switchback 700
Default Yamaha exciter clutch sticking?

I have a red 1991 yamaha exciter, some times the clutch sticks sometimes it doesnt, Its so bad, sometimes in order to start it, I have to spray silicone on the primary sheave so it will spin enough to start up, then at idle, it will often "pull away" even when your not on the throttle, if you set the parking break the engine dies, the idle is set a 1500, I greased the slides on clutch, still no go?

Does anyone have any idea, my next idea is to run machine inside on stand and make sure both clutchs engage and disengage?
pillnoob is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-19-2011, 09:02 AM   #2 (permalink)
Super Advanced Member
 
twincam88's Avatar
 
Join Date: Dec 2008
Posts: 603
Current Sled(s): 2010 nytro mtx
Previous Sled(s): 99 sx700
Location: yorkton sk
Favorite Riding Area: revy
Age: 33
Riding Since: 5
Default

what is your belt deflection maybe it too tight. there should be about 1 inch of up/down movment. is it the right belt? when you say sticking is it down in the secondary /up in the primary?
__________________
wide open till you see god then brake

hesitation means devastation
twincam88 is offline   Reply With Quote
Old 01-11-2012, 05:22 PM   #3 (permalink)
Newbie
 
Join Date: Dec 2011
Posts: 7
Current Sled(s): 03 SXR 600 Triple, 97 V-Max 600
Previous Sled(s): 1989 exciter 570
Location: upstate NY
Favorite Riding Area: my backyard
Default

Is it sticking or stuck? The bushings in the clutch weights wore through on my exciter allowing them to ride up and over the rollers essentially locking the clutch slightly engaged. cant go wrong by pullin er apart and takin a look while you clean it out. most of the time they are just full of belt shavings and dirt.
BlueStreak600T is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 11:56 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0